Microsoft Access 2003 - A Beginners' Guide

This document is an introduction to Microsoft Access 2003, running under Microsoft Windows XP. For further information see Microsoft Access 2003 - An Intermediate Guide.

Introduction

A database manager is a computer program for storing information in an easily retrievable form. It is used mainly to store text and numbers (for example, the Library catalogue, which includes the author, title, class number and accession number for each book). Most modern database managers also allow the storage of other types of information such as dates, hyperlinks, pictures and sounds. As well as being able to store data, a database allows you to select information quickly and easily (for example, a list of the books written by a particular author or those on a certain subject). Finally, it may allow you to produce printed summaries (reports) of the information selected.

When setting up your own database, it is important to plan its use in advance. This is particularly important if you are setting one up which will be used by other people. Among the things which you should consider are:

- What information you will need to store
- What information you want to get out
- Who the data is intended for and how other users will use it
- Whether you want to restrict access to parts of the data to some users only
- Who is allowed to add or change data
- If your data refers to actual people, it may need to be registered under the Data Protection Act

Although you can change the specifications of your database as you develop it, you will save yourself a lot of work if as much as possible is planned in advance.

Microsoft Access is a relational database management system (which allows you to link together data stored in more than one table). It is fully supported by IT Services and is available for departmental purchase under the Microsoft Select Agreement.
Starting Microsoft Access

If you are using an IT Services machine, login as usual by entering your username and password. Then, to start up the program:

1. Open the Windows Start menu and choose All Programs
2. Select Microsoft Office then Microsoft Office Access 2003

Tip: You can drag the Microsoft Access entry from the menu onto the Desktop to create an icon for future easy access.

The Access Screen

On entering Access you are presented with a blank screen, apart from the menus, toolbar and Getting Started Task Pane (on the right). You can now either create a new database or open an existing one. In this course you are going to use an existing database, to see how it is set up and how it can be used. When setting up your own new database, you can start off with a blank database or, for certain business applications, use a template wizard.

1. Click on the [Open] button (or open the File menu and select Open...)
2. An Open window appears - change Look in: to User (D:)
3. Double click on the folder called Training to open it
4. Click on **example.mdb** from the list which appears and press <Enter> or click on [Open]

*Note: For those using these notes on a computer not run by IT Services, the example file can be downloaded from the link provided at step 4 above.*

Users are welcome to take a copy of the example file if they want to practice.

**The Database Window**

![Database Window](image)

The next screen which appears shows the *Database* window. This controls navigation within a particular database. A database is made up of several *objects*, grouped into a single file:

- **Tables** - hold the raw data
- **Queries** - extract part of the raw data to produce *dynasets* - dynamic sets of data which can change each time the query is run (to reflect any changes to the data in the tables)
- **Forms** - user-friendly layouts to display data on the screen (either in a table or from a query)
- **Reports** - output files, ready for printing
- **Pages** - for creating/editing WWW pages
- **Macros** - lists of commands to perform particular functions
- **Modules** - programs which expert users write in a programming language called Access Basic to perform tailor-made functions not generally available
The objects are accessed using the buttons down the left of the Database window. As you use the different components, the menu bar and buttons on the toolbar change appropriately. Currently, the Tables are listed. Pages, Macros and Modules are not dealt with in this Beginners' course.

**Tip:** The [Database Window] button always takes you back to the Database window.

**Part 1: Using an Existing Table**

Begin by investigating the table named students. This contains data relating to imaginary students in a fictitious department in the University, but it could equally be members of a club or just information about your friends and relatives. To examine the table, check the name is highlighted, then press <Enter> or click on [Open]. You can also open a table by double clicking on its name.

A new screen, the Table window, appears revealing the data set out in a table. This method of display (known as Datasheet View) shows the data in columns and rows, similar to a spreadsheet. There are a number of entries (records), one for each student, which each take up one line or row of the table. For each student, various items of data are recorded in columns - each column contains one variable (or field).

Immediately below the data is the status bar, which shows you are positioned at Record 1 (of 390). The current record is indicated by an arrow in the column to the left of the data. You can move the indicator down to the next record by clicking on the button immediately to the right of the number 1 on the status bar. The next button to the right takes you to the end of the table - click on this and you should be at Record 390. Matching buttons on the left take you back a single record and back to Record 1 - try out these too. You can also move up and down using the arrow keys on the keyboard. The scroll bar down the right edge of the table window moves the display up and down.

Another scroll bar is provided at the foot of the window for moving the display to the left and right when the records extend over more than one screen. If you want to move from field to field across a record, you can use the <right arrow> and <left arrow> keys or <Tab> and <Shift Tab>. The <End> key takes you to the last field, the <Home> key to the first. <Page
Up> and <Page Down> take you up and down a screen, while <Ctrl Home> and <Ctrl End> take you to the first field of the top record and final field of the last record, respectively.

View:

To see exactly what each record contains and how it has been set up:

1. Click on the [View] button (the first on the toolbar, or use Design View in the View menu)

The Table Design window lists the field names, indicates their data types and also shows the field properties. The screen appears as below:

![Table Design Window](image)

The fields (and properties) are as follows:

- **StudentNo**: A text field containing each student's personal id, as allocated by the University Registrar's Office. Text fields are the commonest type of fields and can be used to store any characters (letters, punctuation, numbers etc). Numbers should be stored as text if not being used in calculations. This field is set up to hold up to 10 characters and a Caption is used to expand the field name. This number uniquely identifies each student - the Required property has
been set to **Yes** and **Indexed** is set to **Yes (No Duplicates)**. This field has also been used to set up a **Primary Key**, which you will learn more about later.

**Tip:** It's good practice not to include spaces in field names (or in the names of tables / queries / forms / etc). Instead, make use of **Captions** to expand the field name (to include any spaces). Not only do you have less characters to type but it makes manipulation of the data much easier if you find you need to use more advanced database features.

2. Press `<down arrow>` to move to the next field (then repeat this for each field):

- **Surname**: A **text** field containing the Family Name of each student. This field is can hold up to 25 characters
- **Title**: Another **text** field but this time for up to 4 characters. Here, we know the possible values (Mr/Mrs/Miss/Ms) and can set up a **Validation Rule** to check that the data entered is correct - if it is not, the **Validation Text** is displayed. A **Default Value** (Mr) has also been set
- **FirstName**: Another **text** field for student's first name - up to 20 characters
- **OtherInitials**: A **text** field for any other initials - up to 6 characters
- **Hall**: Another **text** field where the possible values are known (the University only has certain Halls of Residence) so a **Validation Rule** has been set - up to 12 characters. A **Default Value** (Private) has also been set
- **Userid**: This is the student's computer username, which doubles as an e-mail address - a **text** field for up to 8 characters
- **Tutor**: The student's tutor - again a **text** field for up to 20 characters
- **Option**: A **number** field which points towards different optional course modules the student can study. Numbers can be stored using different field sizes; here, as the number of options is small (and always +ve) a **byte** is used - see the **Appendix** for a full explanation. A slightly different **Validation Rule** is used to check the data entered
- **DOB**: The data type here is **Date/Time**, which has been set up in **Medium Date** format. Note that a **Caption** is used to expand the field name.
- **Street**: First line of the student's home address - a **text** field storing up to 50 characters
- **Town**: The student's home town/city - a **text** field storing up to 20 characters
- **PostCode**: The student's home post code - a text string storing up to 10 characters
- **Phone**: The student's home telephone number - note that even though this is a number it is stored as text (you won't be doing any mathematical calculations with it!)
- **Overseas**: A Yes/No (or logical) field storing whether the student is from an EEC country or not. The *Default Value* is set to *No*.
- **Notes**: For any other pieces of information - for longer pieces of text, a memo is used
- **Photograph**: Graphics (e.g., a passport photograph) are stored as OLE Objects

Other data types exist which are not included here, namely: currency, autonumber and hyperlink (see the Appendix for details).

**Tip**: Note that the student's surname is stored separately from the first name (similarly each line of the address is in a separate field). Information should always be stored in its component parts. You can then, for example, sort by surname then first name, or reference the students formally (i.e., Mr X) or informally. You will see later how to combine this data into a single field, if you need to.

To close the *Table Design* window and return to the top of the datasheet:

1. Press <Tab> to move to the Surname field
2. Click on the [Find] button (or press <Ctrl f> or use Find... in the Edit menu) and a Find and Replace window will appear
3. The cursor is already positioned in the Find What: box - type in Smith

The default options should already be set correctly. The Look In: box shows the search is restricted to the current Surname field (alternatively, you can search the whole table). In the Match: box, you can choose to match the
**Whole Field, Any Part of Field or the Start of Field. Search:** is set to All records; the other options are Up and Down. **Match Case** lets you distinguish capitals from lower case (if you need to). Finally, **Search Fields as Formatted** is useful for finding data as displayed (a date format, for example). Note that you also have access to a Replace tab for editing data.

4. Press **<Enter>** for [Find Next] and the search should be carried out
5. Press **<Enter>** again and another Smith will be found
6. Keep pressing **<Enter>** until you get the message that the search item is not found

Obviously, this is not a very elegant way of retrieving information from the database - but it works! To close the **Find** window:

7. Press the **<Esc>** key or click on [Cancel] - or click on the [Close Window] button
8. Finally, press **<Ctrl Home>** to move back to the first record

**Sorting**

The records, as you have seen them so far, are shown in the order that they were first entered into the database - as the data came from the Registrar's Office, it is in Student Number order. For this reason, it wouldn't have been easy to search for Smith simply by scrolling through the records (and imagine trying to find a book in the Library if they were all listed by their accession number!). If the data is sorted, however, then you can scroll through the records to search for a particular one.

**Quick Sort**

To sort any field into alphabetical/numeric order, a quick sort facility is provided. First, you have to move to the column on which the sort is to be based:

1. Press **<Tab>** to move to the **Surname** field
2. Click on **[Sort Ascending]** (or use Sort then Sort Ascending from the Records menu)

The names of the students are now in alphabetical order. Note that only the screen display is sorted - the records are still stored in the order in which they were typed, and they always will be.
3. Use Remove Filter/Sort in the Records menu to reset the data to its original unsorted order

**Changing the Display Order Permanently**

If you want to keep the new display order for the next time you open the table, all you have to do is close the table, saving the changes to its design. Try this next:

1. Move to the field you want sorted (eg Surname)
2. Click on [Sort Ascending] (or [Sort Descending] if you want the data in reverse order)
3. Close the table by clicking on its [Close] button (or use Close from the File menu)
4. Save the changes to the table design when asked - press <Enter> or click on [Yes]
5. At the Database window, [Open] the table again - you should find it in the new order

**Note:** it's very easy to accidentally save unwanted changes to the table design (if you perform a quick sort on another field, for example). Use Remove Filter/Sort to get back your original table.

**Sorting in a Query**

Sorts can also be carried out and stored in a query. Moreover, within a query you must set an explicit sort otherwise the records are displayed in their original order of entry. Queries are particularly useful where you have more than one field you need sorted - a simple quick sort only lets you sort on the one field (you can't for example sort by surname then firstname). By using a query you can produce a display sorted on any of the fields and can even create complex sorts within sorts. You will be looking at queries shortly, and carrying out sorts in them, so there is no need to carry out an example here.

**Indexes**

An index, like in a book, is used to speed up searching, sorting and grouping data - one should be set on any fields used frequently in these ways. What happens is that Access records the sort order in a hidden file so that it doesn't need to repeat the sort each time. Indexes also perform a second useful function in that they can be used to guard against duplicate data entry. They are always used when a field is set up as a Primary Key. Try setting up an index on another field:
1. Click on the [View] button to switch back to Design View
2. Note that the StudentNo field already has an index - set to Yes (No Duplicates). As this is used as the **Primary Key**, it must have this setting

The **Surname** field has an index of **Yes (Duplicates OK)**. This field is frequently used for sorting and duplicate values are allowed - as you have already seen with **Smith**. Try setting an index on **Hall** - another field likely to be used in sorting/selecting:

3. Click on the **Hall** field and, using the list arrow, set **Indexed** to Yes (Duplicates OK)
4. Next click on the **Userid** field and note the index here is set to Yes (No Duplicates). The values in this field should be unique and the index will ensure this
5. Click on the [View] button again to switch back to Datasheet View. When asked, press <Enter> or click on [Yes] to save the changes to the design of the table

### Adding, Editing and Deleting Records

**New Record:** 🎨  **Delete Record:** ✗

Whenever you make any changes (additions, deletions or edits) to a table, it is the original data file that you are altering. Unlike most other applications, a database does not make a working copy of the file first. For this reason, it is essential to keep a back-up copy of your file (to which you can always return), just in case you make mistakes when carrying out amendments.

To add a new record to the database, use the [New Record] button (to the right of [Find] or the far right button on the status bar) or **New Record** from the Insert menu. New records are always added at the end of the existing data. As soon as you start to type, Access creates a new empty record (marked with an asterisk), while the current record indicator changes from an arrow to a pencil:

1. Click on the [New Record] button - you should now be on Record 391
2. Type in a number for the StudentNo (anything under 1000 will do) then press <Enter> (or <right arrow> or <Tab>) to move to Surname
3. Type in your own name then move to Title (press <Tab>, <Enter> or <right arrow>)
4. Repeat step 3 until you have filled out most of the record

Note that some fields already have a default value. To change a value in a field you simply type in a new one. Note also that some fields (eg Hall and Option) can only accept certain values, others (eg StudentNo, Surname and FirstName) cannot be left blank.

The Photograph field can hold a picture. The best way to add one is via the Clipboard (ie Copy and Paste). If you use the menu system (choosing Object... from the Insert menu) then it may appear as an icon which you then have to double click to open. As pictures cannot be displayed in Datasheet View anyway, don't try filling out this field here.

Note: An alternative method for entering new data is provided by the Data Entry command in the Records menu. With this, an empty table is displayed into which you type in the data. The best method for entering data, however, is via a form, which you will be meeting later.

To delete the current record (in this case your own):

1. Click on the [Delete Record] button (to the right of [New Record] on the toolbar)

Deleting records from a database is potentially very dangerous as they are erased once and for all, hence you are given one final chance to change your mind:

2. Press <Enter> for [Yes] to confirm the deletion

Note that you can't now use [Undo] to recover the record. If you have several records to delete:

3. Using the mouse, point to the left-hand edge of the first record to delete (where the current record indicator is held) - you will find that the mouse cursor changes to an arrow
4. Hold down the mouse button - the record is marked (it becomes white on black) - then drag through the records required
5. To delete them, click on the [Delete Record] button (or just press the <Delete> key or use Delete from the Edit menu)
6. When asked to confirm the deletions, this time click on [No] and the records will reappear
**Note:** Records must be next to each other in order to delete them (you cannot use `<Ctrl>` click like you can in other Microsoft software, though `<Shift>` click can be used to select a block of records). You will see next how to select a subset of non-contiguous records, which you could then delete.

**Selecting Records**

Databases offer you the facility of extracting sub-sets of records according to some pre-set conditions - in the Library, for example, you can search for all the books written by a particular author or all those dealing with a given subject. Access offers you two methods for selection, *Quick Select using a Filter* and *Selection using a Query*.

**Quick Select**

Simple selections can be made directly on the table itself, using a filter. Try out a few examples:

1. Press `<Ctrl Home>` to move to the first record
2. Move across to the *Hall* field - to find all the students living in a particular hall
3. Using the `<down arrow>` key, select the Hall of Residence you require (or you could use [Find] to search for a particular Hall)
4. Click on the [Filter by Selection] button (to the right of [Sort Descending])

Note that at the bottom of the screen it says *Record 1 of XX (Filtered)*. To turn off the filter:

5. Click on the highlighted [Remove Filter] button (to the left of [Find])

You can also filter on part of a field - for example, you might want all the students registered in 2004:

6. Move to the *UserId* field
7. Find a record containing 04 and drag through the figures to select them (ie just 04)
8. Click on the [Filter by Selection] button to carry out the filter

If you now also wanted to find the students in this year who had a particular tutor:
9. Move to the *Tutor* field
10. Move down to a record with the required tutor (or use [Find])
11. Click on the [Filter by Selection] button

Note that this command is also available from **Filter** in the **Records** menu. Another command here (which is not on a toolbar button) is **Filter Excluding Selection**.

Having made your required selection, there are several things you might want to do next. For example, you might want to delete these records - even though they are not next to each other in the full dataset, you could drag through them here and delete them as before (but don't do so here).

Another thing you might want to do is to print off the data. However, you probably wouldn't want all of the fields, so you'll see next how to hide unwanted columns.

**Changing the Fields Displayed**

Tables often contain a lot of data, only some of which may be required. You can control which fields are shown and which hidden. Here, you may want just the student name and hall of residence:

1. Click in any *StudentNo* record then open the **Format** menu and choose **Hide Columns**

To hide several adjacent columns in one go:

2. Position the mouse cursor into the *Userid* column heading (the pointer changes shape to a down arrow)
3. Hold the mouse button down and drag through the remaining column headings to the end - the columns go black
4. Open the **Format** menu and again choose **Hide Columns**

If you want to change the order of the fields on the screen, you can either use cut and paste or, more simply, drag and drop. Both these techniques should be familiar to the Microsoft Office user. To list the students starting with their full name (including title) in the correct order:

5. Click on the *Surname* column heading to select the column
6. Move the mouse cursor back into the column heading, hold down the mouse button then (with the button still depressed) drag the column to the right to a position immediately before the *Hall* field
7. Let go of the mouse button to drop the field in its new position
Note: you are only changing the screen display - the data is still stored in its original order.

Finally, you might want to print your list. First, it's a good idea to preview it:

8. Click on the [Print Preview] button - the mouse cursor becomes a magnifier

You will notice that Access automatically adds a header and footer to your page, which you may or may not want. Normally you would now print your list, but here:

9. Click on the [Close] button to turn off the preview

To redisplay some of the hidden fields:

10. Open the Format menu and choose Unhide Columns ...
11. Click in the box against a hidden column to redisplay it
12. Once all the required fields are ticked, press <Esc> or click on [Close]

Tip: The simplest way to redisplay all the fields is to close the table without saving the changes to its design. When you reopen it, it will appear in its original format.

Advanced Filters

The relationship between queries and filters is a very close one. You can in fact save a filter as a query by turning on the advanced filter option. This can be a useful aid in designing a query. Save the current filter (students with a set tutor who came in 2004), as an introduction to queries.

To save the filter:

1. Open the Records menu, choose Filter then Advanced Filter/Sort...

A Filter Design window appears. This is very similar to the Query Design window, which you will be using next. Examine how the criteria have been set up.

2. Open the File menu and choose Save as Query
3. Save the filter as Tutor04 (press <Enter> for [OK]), then [Close] the filter window
4. Close the students table - don't save the changes to the design (click on [No])
To rerun the filter:

6. Move to **Queries** in the *Objects* list of the *Database* window
7. Select **Tutor04** and press `<Enter>` to [Open] it
8. End by closing the query - click on its [Close] button

Once a filter has been saved as a query, it's easy to modify its design if necessary.

Using a filter in this way is straightforward but a little limited. You can't, for example, find all the students with either Tutor X or Tutor Y. To do more complicated selections such as this you have to use a *Query*. Queries also offer various other facilities, as you will see.

**Selection using a Query**

To introduce you to queries (which may look a little complicated at first, but which are in fact very easy), try repeating some of the selections you have just done. There are four ways to start a query:

- You can use the [New Object] button, choosing **Query**
- You can choose [Create query in Design view] from *Queries* in the *Objects* list
- You can choose [Create query by using wizard] from *Queries* in the *Objects* list
- You can click on the [New] button when viewing *Queries* in the *Objects* list

Here, try the first method:

1. Click on **Tables** in the *Objects* list and check the **students** table is selected
2. Click on the *list arrow* attached to the [New Object] button on the right and choose **Query**
3. In the next window, accept the default *Design View* - press `<Enter>` or click on [OK]

Note: Whenever you start up a query from a table, the query is automatically based on that table.
The *Select Query* window may look a little confusing, but in fact it's very simple to use. The cursor should be flashing in the *Field: row* in the lower part of the screen waiting for you to define which fields are to be displayed. The first quick selection you carried out was to display all the data for students in a particular hall of residence, so try to repeat that here:

1. Click on the list arrow on the right of the *Field: cell* and choose `students.*`

The *asterisk* notation means *all* the fields in the `students` table (if you only wanted certain fields displayed you must choose them individually).

You are going to select all students from a particular hall, so you need the *Hall* field in a separate column to set up the selection criteria. Another way to fill up a field is to drag it from the `students` field list in the top half of the *Select Query* window. You can try this next:

2. Scroll down to display the *Hall* field then drag it from the `students` list to the *Field: row* in the second column. Release the mouse button to drop the field heading into position
3. Unset the *Show: box* in column 2 by clicking anywhere in the cell (the check box will become blank) - if you don't, the hall will appear twice as it's already in `students.*`
4. Move down to *Criteria:* in column 2 and type the name of the required hall - eg `Childs`
5. To carry out the query, click on the [Run] button (or you can click on [View] to move from Design View to Datasheet View)

The main difference between this query and the earlier quick select is that you can keep it for future use - quick select just applies a filter to the
underlying table whereas a query can be saved as a separate entity. You can build up a range of queries and then run them as required - for example, next term or next year you might want a new list of students living in a particular hall of residence.

6. Click on the query window's [Close] button (or use Close from the File menu)
7. When asked, press <Enter> or click on [Yes] to save the query
8. Save the query as Hall - press <Enter> or click on [OK]

Note: You can't give a table and query the same name.

Now try re-running the query:

9. At the Database window click on Queries in the Objects list
10. Select the Hall query and press <Enter> or click on [Open] - you have your results again

Parameter Queries

The selections you have carried out so far have only met fixed criteria - in this case: Show me the students who live in Childs (or whichever) Hall. With a query, however, you can change the criteria each time you run it by making it a parameter query. The design is very similar to what you have already seen except that instead of setting a fixed criteria Access asks for the information at run time. Modify the Hall query to do this:

1. With the Hall query still open, click on the [View] button to change to the Design View
2. Click in the Criteria: field in the second (Hall) column and <Delete> the current criteria
3. Type in a new criteria saying: [Which Hall?]

Note: square brackets tell Access that this is a question, to be displayed at run time.

4. Click on the [Run] button (or switch to Datasheet View)
5. When asked the question Which Hall? type in the required hall of residence - eg Bridges
6. Press <Enter> or click on [OK] and the query will be run
Normally, you would run the query each time from the Database window (or from a user-friendly interface - a form called a switchboard). Here, however, to run the query again:

7. Click on the [View] button to change to the Design View
8. Click on the [Run] (or [View]) button again
9. Type in the name of a different hall - eg Windsor - and press <Enter> or click on [OK]

As you can see, this query is much more useful than when it only worked for a set hall.

More Complex Queries

Next, try some more complicated queries. What if you want to have an alternative criteria? For example, you might want a list of students living in either one hall or another. To do this, you have to set up criteria on two different lines.

1. Click on the [View] button to change to Query Design
2. In the second line of the Criteria: in column two, type: [or?] for a second question
3. Click on the [Run] button (or switch to Datasheet View)
4. When asked Which Hall? type in the name of the first hall - eg Wells (press <Enter>)
5. When asked or? type in the name of another hall - eg Wessex (press <Enter>)
6. You now have the students from both halls - [Close] the query, saving the new design

You have seen how to match values in a query but you can also use criteria such as greater than, less than, not equal to, between one value and another, or matching part of a field. For example, how do you set up a query to pick out the students who came in 2004? The answer is that you have to use a special notation called Like.

The Like notation indicates that the words which follow must be embedded within the data in that field for a record to be selected - wildcards (* or ?) can be used to denote characters which may precede or follow the required text. ? represents a single character whereas * represents any number of characters. For example, Like C* could be used to give you all the students with names beginning with the letter C, while Like *son would match students whose names ended with son. For the 2004 students:
1. Check you are viewing Queries in the Database window
2. **Double click** on **Create query in Design view** or use **[New]** and accept **Design View**
3. In the **Show Table** window, click on the **Tables** tab, select **students** and **[Add]** it

Because the query wasn’t started from a table you have to add it explicitly this time.

4. Press **<Esc>** or click on **[Close]** to close the **Show Table** window
5. Set the **Field:** in the first column to **students.**

**Tip:** A third way to set up the fields is to **double click** on the field names in the field list in the top half of the **Select Query** window. This automatically fills up the next empty **Field:**

6. Set the **Field:** in the second column to **Userid**
7. Move down to **Sort:** and type **a** to get a list sorted on the students’ usernames
8. Turn off **Show:** by unticking the box
9. In **Criteria:** in the second column type: **04** and press **<Enter>**
   (Access automatically changes this to **Like "04"** for you)
10. Click on the **[Run]** button to run the query - or switch to **Datasheet View**

To set up a second condition on this subset of data (eg 2004 students who have a particular tutor) is very easy. Whereas alternative conditions are set up on different lines, simultaneous conditions must be set up on the same criteria line:

11. Click on the **[View]** button to move back to **Design View**
12. Set the **Field:** in the third column to **Tutor**
13. Turn off **Show:** by unticking the box
14. In **Criteria:** in the third column, top line, type: **[Which Tutor?]** - or set a fixed value
15. Click on the **[Run]** button to run the query - or switch to **Datasheet View**
16. When asked **Which Tutor?** type in the name of a tutor (eg **Foot**) - press **<Enter>** for **[OK]**
17. **[Close]** the query, saving it as **2004**
Adding a New (Calculated) Field

Earlier, you did a very simple selection to show just the student's name and hall of residence. You are going to repeat that next, to demonstrate how to include only certain fields in a query. One fault with the original example was that the students' names (first name and surname) were printed in separate columns. In a query you can calculate a new field, joining these together:

1. Check you are viewing Queries in the Database window
2. Double click on Create query in Design view or use [New] and accept Design View
3. In the Show Table window, click on the Tables tab, select students and [Add] it - press <Esc> to [Close] the window
4. In Field: in column one, type: FullName: FirstName & " " & Surname (don't forget the space between the double quotes or the names will merge into a single word) - press <Enter>

Tip: You should always use an ampersand (&) rather than plus (+) sign when joining text together. Though both appear to work, plus signs can occasionally cause problems.

5. Set the Field: in the second column to Hall
6. Set the Field: in the third column to Surname - you need surname for sorting your list into alphabetic order, however, you don't want it displayed twice
7. Set Sort: in column 3 to Ascending - type a in this cell
8. Turn off Show: in column 3 by unticking the box
9. Click on the [Run] button to run the query - or switch to Datasheet View
10. Double click on the dividing line between the column headings to widen the FullName column

With a query you can sort on more than one field if you want - a sort within a sort. Here, you might want to sort first by Surname and then by FirstName (for example, if you move down to the students named Berry - use <Page Down> - you will see they are out of order). Sorts are carried out from left to right across the columns in the query - if the fields are not in the correct order, simply drag and drop them as required.

11. Click on the [View] button to move back to Design View
12. Set the Field: in the fourth column to FirstName
13. Set **Sort**: in the fourth column to **Ascending** - type **a** in the cell
14. Turn off **Show**: in column 4 by unticking the box
15. Click on the **[Run]** button (or switch to **Datasheet View**) again to see the results
16. Check the **Berry**'s then **[Close]** the query, saving it as **Names**

**Using a Form**

The next object to investigate is a **Form**. Forms are used to facilitate data input and allow you to set up your own data entry screen. Forms can also be used for queries. A data entry form has already been set up for the students table:

1. At the **Database** window, click on **Forms** in the **Objects** list
2. Select the **students** form and press **<Enter>** to **[Open]** it

![students form](image)

A user-friendly screen is displayed, with a title at the top and the various fields listed and boxed. The menus, commands and buttons work as they did before, allowing you to move around, add new records, delete records, filter, sort and search etc.
3. Move to the *Surname* field (press `<Enter>`, `<Tab>` or `<right or down arrow>`)  
4. Click on [Sort Ascending] to sort the forms into alphabetical order  
5. [Close] the form then reopen it - the sort order remains, as it did with the table

Forms also provide short-cuts to data entry, including letting you select from a list of valid values. Use this form type in your own information again:

6. Click on the [New Record] button or use **New Record** from the **Insert** menu  
7. Fill in the fields with your own information, as you did before  
8. In the *Title* field, select the required title using the **list arrow**  
9. In the *Hall* field, start typing the name of the hall and watch Access select from the list of possible values (alternatively, choose from the list using the **list arrow**)  
10. The *Tutor* field also has a **list arrow** attached  
11. The *Overseas* field appears as a check box - click on it to set it on if necessary  
12. In the *Notes* field, type several lines of text (type rubbish text, if you like) and watch how the box accommodates it. Press `<Tab>` to move to the next field (the `<down or right arrow>` keys don't work, while `<Enter>` gives you a new paragraph!)  
13. For a *Photograph*, as you probably haven't got a picture file handy, press `<Alt PrintScreen>` to dump the current window then [Paste] it from the *Clipboard* into the field  
14. End by deleting your own record - click on the [Delete Record] button (press `<Enter>` for [Yes] - or click on [No] if you want to keep it)

**Form Design**

Though forms are very easy to use, they are not that easy to design. Fortunately, Access has wizards to do most of the work for you. However, if you wish to modify a wizard-designed form, you will find it very difficult until you are familiar with the program. To view the form design:

1. Click on the [View] button to move to Design View  
2. Note that Access provides you with a **Toolbox** to help you with the design

You are not going to modify the design of this form - you will see how to later, in Part 2 of these notes. For the moment:
3. Click on the [View] button to move back to Form View

**Filter by Form**

When using forms, if you want to select a subset of the records using a filter, you can still use the [Filter by Selection] button as before. However, this isn't very convenient if you want to base the filter on information not displayed on the current form. Here, for example, you might want to search for all the students living in Wells Hall (which isn't the hall on the current record). Access provides a special filter button for use with forms (the middle of the three filter buttons).

1. Click on the [Filter by Form] button (the middle one of the three filter buttons)
2. If the form is not empty, click on the [Clear Grid] button
3. Click on the list arrow attached to the Hall field and select Wells
4. Click on the [Apply Filter] button - you should now have just 21 records (use <Page Down> to move through them)
5. Click on the [Remove Filter] button to see all the records - note that the same button is used for applying or removing a filter
6. Close the form by clicking on its [Close] button - or use Close from the File menu

Note that you are not asked to save the changes to the design of the form (you are with a table). Any sorting is saved automatically; any filtering is discarded. Note also that you can use [Filter by Form] on a table. Here you are given a blank record into which you type the required criteria.

**Using a Report**

The fourth object button in the *Database* window is *Report*. This allows you to create (and store) reports which can then be printed.

1. Click on Reports in the Objects list

A report for the students table has already been prepared (you will see how to create a report later):

2. Check students is highlighted it and press <Enter> for [Preview] - you may need to [Maximize] the window
3. The mouse button acts as a zoom facility - position the magnifying glass over a particular piece of text and click on the mouse button to magnify it.

4. Use <Page Down> or the page selection buttons at the foot of the Preview window to move to other pages.

To see how the report is designed:

5. Click on the [View] button to move to Design View.

Note how similar the Report Design and Form Design windows are - you have the same Toolbox to draw the various components. Again, you will see how this is done later.

6. Click on the [View] button again to move back to Print Preview.

7. Close the Report - click on its [Close] button or use Close from the File menu.

Part 2 : Creating a New Table

In this next section you will be creating your own table (and form). You will then type in a couple of records - the rest you will retrieve from a file.

Designing the Table

As much as possible of a table design should be done in advance on paper. Here, however, you will be creating the table on the screen so that you can see the stages as they are implemented. The table you are going to create contains information about the Halls of Residence at the University. In Part 3 of these notes, you will see how to link this information to the data in the students table:

1. Click on Tables in the list of Objects in the Database window.

2. In this window, click on [New] for a new table.

You are now offered various alternatives (the first three of which can also be accessed from special buttons on the tables tab in the Database window):

- Datasheet View creates a dummy datasheet for you, with the fields named as Field1, Field2 etc. As you enter data into the fields, Access recognises the type of data entered and allocates a Data Type to it (eg if you type a date, the field will be set up as a Date/Time field). To
name the fields, double click on each column heading and type in its new name

- **Design View** lets you do everything yourself, from scratch
- **Table Wizard** has predefined **Sample Tables** (eg Employees, Addresses, Inventories) for both Business and Personal applications. Each sample table has suggested fields, which you may or may not want to include in your own table design. Wizards have the disadvantage that they sometimes try to be too clever and are very much geared to the American market (eg Addresses have States, not Counties)
- **Import Table** and **Link Table** allow you to import data from or link the table to another file, respectively. This file could be an Excel spreadsheet, for example, or another database

To understand the fundamentals of table design:

3. Choose **Design View** - press <Enter> or click on [OK]
4. The first field is for the name of the hall - type in **Name** and press <Enter>

*Note: It's important that you name the fields exactly as specified in these notes for one of the later exercises to work.*

5. The **Data Type** is **Text** by default - press <Enter> as this is what you want for this field
6. The **Description** is optional - type in **Name of Hall of Residence** if you want
7. Move down to the **Field Properties**

*Tip: Key <F6> can be used to Switch panes - or you can use the mouse.*

8. Set a **Field Size** of 12 and press <Enter>

If you need to increase the field size at some time in the future there should be no problem. However, if you ever choose to decrease it then you could lose some data.

9. Set up a **Caption** of **Name of Hall** then **Required** to **Yes**
10. Set **Indexed** to **Yes (No Duplicates)** - it's worth putting an index on this field since it is likely to be used for sorting and it also insures that the data for a particular hall is not entered twice
11. Move to the second row - press <F6> and <Enter>, or use the mouse
12. Set the *Field Name* to **Warden** and the *Data Type* to **Text**

You could now fill in the *Description* and set some *Properties* but, to speed things up, just leave the settings for this (and subsequent fields) as they are.

13. Press `<down arrow>` to move to the third field
14. Set the *Field Name* to **Phone** and the *Data Type* to **Text**
15. Press `<down arrow>` to move to the fourth field
16. Set the *Field Name* to **Road** and the *Data Type* to **Text**
17. Press `<down arrow>` to move to the fifth field
18. Set the *Field Name* to **Town** and the *Data Type* to **Text**
19. Press `<down arrow>` to move to the sixth field
20. Set the *Field Name* to **Students**, the *Data Type* to **Number** (for a *Description* add *Number of students living in the Hall*) and the *Field Size* property to **Integer**
21. Move to the seventh field
22. Set the *Field Name* to **Meals**, the *Data Type* to **Yes/No** (for a *Description* add *Are meals provided?*) and the *Default Value* property to **Yes**

Note: The *Lookup* tab in the *Field Properties* allows you to set up a different *Display Control* on a form or table. For a Yes/No field, this is set to *Check Box* but can be *Text* or *Combo Box*:

23. For the **Meals** field, click on the *Lookup* tab and set *Display Control* to **Text Box**

**Setting up a Primary Key**

![Primary Key](image)

Whenever you design a new table, it's a good idea to set up a *Primary Key* on one of the fields. Primary Keys help Access uniquely identify each individual record in a table and hence work more efficiently. If a table doesn't contain a unique identifier then Access will ask to set up an ID field for you. Here, the *Halls of Residence* table already has a unique field - the name of the hall:

1. Click on the *Name* field (row 1)
2. Click on the [**Primary Key**] button - a key symbol appears in the *field indicator* column
3. Click on the [View] button to move to Datasheet View
4. When asked (press <Enter> for [Yes]), save the table as HoR - press <Enter> or click on [OK]

You could now type in your data, if you wanted to. Using a datasheet isn't very friendly, however, so try setting up a special data-entry form. A form gives you more control over what data is entered and can be designed to cut down on typing mistakes, as you saw with the students form.

Creating a Data Entry Form

There are two simple ways of creating a form, you can either use a Form Wizard or AutoForm. AutoForm is a very quick and easy way to produce a form - it does so at the click of a button:

1. With the HoR table still open, click on the down arrow attached to the [New Object] button and choose AutoForm - the form appears instantaneously in a new window
2. Click on its [Close] button to Close the form - don't save it this time (click on [No]) as you will be creating the form using a Wizard next
3. Close the HoD table by again clicking on its [Close] button

The Form Wizard is equally easy to use and offers you various additional options.

1. At the Database window, click on Forms in the Objects list and then on [New]
2. In the New Form window, click on the list arrow and set the data source for the form to HoR
3. Click on Form Wizard then press <Enter> or click on [OK]

You are now asked which fields you want to appear on your form (here you have the choice - AutoForm gave you them all). As it happens, for a data entry form, you need all the fields:

4. Click on the double arrow [>] to move them all (alternatively select individual fields in the order you want and use the [>] button) - press <Enter> or click on [Next>]
5. Choose a layout for your form (explore the alternatives, if you like, but ignore PivotTable and PivotChart) - Columnar is best (press <Enter> or click on [Next>])
6. Set a *style* for your form - choose **Standard** (press `<Enter>` or click on **[Next]>**)  
7. Add a title - accept **HoR** (press `<Enter>` to **[Finish]**)  

The form is now opened for you to use. As it stands it is neat and simple, but a little boring - in fact it's exactly the same as that produced using *AutoForm*. To improve it:

**Toolbox:**  
**Label:**

8. Click on the **[View]** button (to move to *Design View*)  
9. Enlarge the *Form Design* window - click on the **[Maximize]** button (to the left of **[Close]**)

Forms have three (sometimes more) sections - a *header*, *footer* and the *detail*. The data itself is entered into the detail section; the header and footer can be used for titles etc. To add a title:

10. Position the mouse over the border between the *Form Header* and *Detail* - the cursor should change shape to a double-headed arrow.  

    Hold the mouse button down and drag the border down one unit (there's a scale on the left-hand side)  
11. Click once on the **[Label]** tool in the **Toolbox** - the mouse pointer now has an A attached

**Tip:** If you accidentally close the **Toolbox**, you can redisplay it by clicking on the **[Toolbox]** button (or select **Toolbox** from the **View** menu).

12. Move the pointer into the form header (top left corner) and click once  
13. A small label box is drawn - type your form title: **Halls of Residence - The University of Reading**  
14. Press `<Enter>` and the label box is completed  
15. Change the **[Font Size]** (eg to 14 point) and click on **[Bold]** to make the title more imposing  
16. To display the enlarged title, *right click* on the label box and choose **Size** then **To Fit** (this command can also be issued via the **Format** menu)

To add colour:

17. *Right click* on the *label* box and choose **Font/Fore Color** - pick a colour to apply to your title
18. Right click on the header background (away from the label) and choose a Fill/Back Color

19. Repeat the process to change the colour of the detail background, other labels/text boxes etc

**Tip:** Use the [Format Painter] to copy the colour scheme of one label or text box to the others - this speeds things up and gives a better overall design.

20. Press `<Ctrl s>` (or click on the [Save] button) to save the changes to the design of the form - the name of the form is picked up automatically as HoR

21. Click on the [View] button to move to Form View

The form is now ready for you to type in the data.

**Entering Data Using the Form**

You are now going to use the form to enter a couple of data records:

1. For the first record, type in the following:

   Name: Bridges (and press `<Enter>`)  
   Warden: Dr R.P.B. Smith (`<Enter>`)  
   Phone: x8647 (`<Enter>`)  
   Road: Whiteknights Road (`<Enter>`)  
   Town: Reading RG6 6BG (`<Enter>`)  
   Students: 458 (`<Enter>`)  
   Meals: the option box is already set on for Yes

2. Press `<Enter>` to move on to the second record, which is as follows:

   Name: Childs (and press `<Enter>`)  
   Warden: Prof A.L. Jones (`<Enter>`)  
   Phone: x8800 (`<Enter>`)  
   Road: Upper Redlands Road (`<Enter>`)  
   Town: Reading RG1 5JW (`<Enter>`)  
   Students: 458 (`<Enter>`)  
   Meals: again, the option box is already set on for Yes

This is all you are going to enter explicitly; the remaining records are going to be imported from a data file created using another package.
3. Close the Form window by clicking on the [Close Window] button
4. Click on the [Restore Window] button (the middle one of the three in the top right corner of the window) to return the Database window to a smaller size

**Importing Data**

Access allows you to bring in information from other sources - this is called importing. Databases vary on how they bring in the data and on which sort of files they can import. If you have a really large dataset, it is a good idea to try importing a small section to a new table first and only if that works successfully to try to import it all.

Access can import data in various formats, including Dbase (another widely-used database) and HTML (from web pages). Microsoft Excel spreadsheet files can be imported directly. Here, the data has been saved as *tab separated values*, which is a standard format which any spreadsheet (or indeed word processor) should be able to produce. Other basic formats include *comma separated values* and just plain *text*. One thing to note when importing a file is that the first line may contain headings - Access has an option to cope with this and can use them for field names.

You should currently be back at the Database window. To *add* the data to an existing table (or create a *new table*) from a file:

1. At the Database window, click on Tables in the Objects list and choose [New]
2. Click on Import Table then press <Enter> or click on [OK]
3. Check that the current directory is set to Training on the D: drive (if using a lab PC; if not, the file can be downloaded via the hyperlink at step 5)
4. Change the Files of type: box to read Text Files by using the list arrow attached
5. Select the file called halls.txt then press <Enter> to [Import] it
6. The Import Text Wizard now starts up. This has several stages, as follows:
   a. Choose whether the data is character (eg tab, comma or space) delimited or fixed width (where extra spaces have been used to line up the data in columns) - press <Enter> or click on [Next>] for Delimited
   b. Choose the delimiter (here, *tab* is correctly chosen) and whether or not the First Row Contains Field Names (here, it *does*, so
**Part 3: Relating Tables Together**

A relational database management system lets you store information in many tables which can then be linked together. This is particularly useful when you have information which is either heavily duplicated or sparse (many records having empty fields). For example, if you have an inventory of equipment, it's better to record information about the suppliers (the name, address, phone/fax numbers, contact etc) in a separate file. Then, in your inventory, you need only record the name of the supplier to find out the other information. As each supplier will be supplying several pieces of equipment, this avoids massive data duplication.

It's the same situation here with the students. There is no need to store information about Halls of Residence for each student - that can be picked up from the HoR table. You'll see next how this is done. The aim of the exercise is to create a list of students, living in hall, such that you can send them a letter to their University address.
1. Click on **Queries** in the **Objects** list at the **Database** window

2. **Double click** on **[Create query in Design view]** or use **[New]** then **Design View**

3. **[Add]** both the **HoR** and **students** tables to your query - press <Esc> or click on **[Close]**

You next have to join the two tables together on a common field. Joins can be created between tables when you design the database (in a special **Relationships** window), or made in a query (in which case they only apply to that particular query).

Tables are automatically joined in a query if two fields have the same name. Here, however, the common field (the Hall of Residence) is called **Hall** in the **students** table but **Name** in the **HoR** table. In this case you have to create the join manually by dragging the field name from one table over to the corresponding name in the other table.

4. Position the cursor over the **Name** field in the **HoR** table

5. Hold down the mouse button and drag the field over the **Hall** field in the **Students** table

When you release the mouse button, a **join line** appears. If you made a mistake, simply click on the join line to select it then press <Delete> and try again. Now you need to set up your query:

6. In column 1, set the **Field:** to **FirstName** from the **students** table
7. In column 2, set the **Field:** to **Surname** from the **students** table
8. In column 3, set the **Field:** to **Hall** from the **students** table
9. In column 4, set the **Field:** to **Road** from the **HoR** table
10. In column 5, set the **Field:** to **Town** from the **HoR** table
11. Sort the data by **Hall** - set **Sort:** to **Ascending** in column 3
12. Click on **[Run]** to run the query - you should find 265 records are displayed (if you spelt Bridges and Childs correctly - the 125 students living in private accommodation are excluded)
13. Click on the query window’s **[Close]** button, saving it as **Addresses**

**Creating a Report**

Earlier you viewed an existing report; now, try to generate some yourself. Reports are saved within the database - you can then modify them at some later date if you need to tidy up the layout, for example. Note that you can also export data to Word or Excel via **Office Links** in the **Tools** menu.
Access gives you the opportunity of designing your own reports from scratch (using Design View), however, unless you are an expert, don’t even attempt this. It’s much easier to use AutoReport or a Report Wizard and then modify the design if you really need to.

**Using AutoReport**

Begin by creating a report for the HoR table using AutoReport.

1. At the Database window, click on [Reports] in the Objects list and choose [New]
2. Use the list arrow to select the HoR table
3. Click on AutoReport: Tabular then press <Enter> or click on [OK]

A report is automatically produced for you. It looks fine, so there is no need to change the design unless you really want to.

4. Click on the report window’s [Close] button, saving it as HoR

AutoReport gives you a very simple report. By using the Report Wizard instead, however, you can set various other options (as you found with the Form Wizard). You'll look at this next.

**Using Report Wizards**

To demonstrate the Report Wizard, you are going to produce a report listing the students by their hall of residence, with the hall address only appearing once for each group of students:

1. At the Database window, click on [Reports] in the Objects list
2. Double click on [Create report by using wizard] or use [New] and the Report Wizard
3. Use the list arrow to select the Addresses query
4. The Report Wizard now goes through six steps:
   a. Move across the fields you want on your report. Here, you want all the fields, so click on [>>] - press <Enter> or click on [Next>]
   b. Step two allows you to set grouping levels. You only need a list of names for each hall, so use the address fields for grouping (these then appear once for each list of names) - move across Hall, Road and Town (using [>]) then press <Enter> or click on [Next>]
   c. Sort by: Surname and then FirstName - press <Enter> or click on [Next>]

d. Choose a **Layout**: **Align Left** 1 is fine - press <Enter> or click on [Next]

e. Choose a **Style** for your report (eg **Formal**) - press <Enter> or click on [Next]

f. Call your report **Addresses** - press <Enter> or click on [Finish]

The resultant report may not be exactly what you want (in fact it looks terrible) but it's easier to modify a design than to create one from scratch. Here, for example, there is no need for the boxes round the headings (or indeed the headings themselves), the address for each hall needs to be in the same style and lined up properly, and the list of students should be on the left of the page.

5. Click on the [View] button to see the **Design View**

6. Open the View menu and select **Report Header/Footer** then click on [Yes] to delete these sections (they aren't needed here)

7. Click on the **Hall** label (the box on the left) in the **Hall Header** and delete it

8. Click on the **Hall** text box in the **Hall Header** and, using the mouse or arrow keys, move it to the far left

9. Repeat steps 7 and 8 for the **Road** and the **Town** boxes

10. Using the mouse in the ruler on the left, drag down through the **Town Header** (very top to very bottom), then <Shift> click on the **Town** text box (to unselect it) and delete everything else

11. Click on the **Hall** text box in the **Hall Header** then on the [Format Painter] button (the brush to the right of [Paste]) and click on the **Road** text box to paint the format

12. Right click on the **Road** text box and choose **Size** … then **To Fit**

13. Repeat steps 11 and 12 on the **Town** text box

14. Finally, click on the **FirstName** text box (to select it) then, using the mouse or arrow keys, move it to the far left - you may also need to move the **Surname** slightly to the right

15. Reduce the height of the **Detail area** slightly - position the mouse on the top of the **Page Footer** (it changes shape to a double-headed arrow), hold down the mouse button and drag the border up just a little

To force each hall onto a separate page:

16. Right click on the **Hall Header** and choose **Properties**

17. Set **Force New Page** to **Before Section** then [Close] the **Properties** window
18. Finally, click on the [Print Preview] button to see the changes you have made.
19. Click on the window's [Close] button, saving the changes to the design of the report.

**Tip:** For a multi-column layout, open the File menu and choose Page Setup.... Then, on the Columns tab, set the Number of Columns and Width as appropriate (eg to columns to 2 and width to 7.9) and change the Column Layout to Down then Across.

Next, try using a special wizard to generate the address labels for the students.

1. At the Database window, click on the [Reports] tab and choose [New]
2. Use the list arrow to select the Addresses query
3. Click on the Label Wizard then press <Enter> or click on [OK]
4. The Label Wizard now goes through five steps:
   a. Setup the size for your labels - check Filter by manufacturer: is set to Avery, change the Units of Measure to English and select the Product number: for your labels (eg 5160) - press <Enter> or click on [Next>]
   b. Setup the Font name and Font size etc which you require (here leave them as they are) - press <Enter> or click on [Next>]
   c. Move the fields across to a Prototype Label by clicking on the arrow provided:
      - move across FirstName, press the <spacebar>, then Surname
      - press <Enter>
      - move across Hall then press <spacebar> and type Hall - press <Enter>
      - move across Road - press <Enter>
      - move across Town - click on [Next>]
   d. Sort by: Hall and then Surname - press <Enter> or click on [Next>]
   e. Call your report Labels Addresses - press <Enter> or click on [Finish]
5. Press <Enter> (for [OK]) to cancel the warning message
6. View the report then click on its [Close] button to close the report

**Tip:** Getting Access reports looking exactly the way you want can be very time-consuming. It may be easier to do the formatting in Word - from the Tools menu choose Office Links then Publish it with Microsoft Office
**Word.** You can also send data to Excel if you want to carry out an analysis of the information.

**Leaving Access**

You should now be back at the *Database* window, where you could continue to work on the students database, adding further tables and queries and producing more reports. When you have completely finished your work, open the *File* menu and issue a *Close* command. This closes any opened tables etc and ensures that the database file is properly shut down.

You could now go on to use or create another database, but the course is now over so open the *File* menu and choose *Exit*. Finally, on the public machines, don't forget to *Log Off*.

**Appendix**

Below is a summary of the different data types and what they are used to store. If you know how a computer works then the seemingly random values make sense. For example, the basic storage unit in a computer is a byte, which can hold 8 zeros or ones. These, in turn, represent whole numbers between 0 and 255. Two bytes can hold 65536 whole numbers (0 to 65535 or -32768 to +32767).

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Format/Field Size</th>
<th>Stores</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Up to 255 characters</td>
<td>Text - including numeric text (eg phone numbers)</td>
</tr>
<tr>
<td>Memo</td>
<td>Up to 65535 characters</td>
<td>Longer pieces of text</td>
</tr>
<tr>
<td>Number</td>
<td>Long Integer</td>
<td>Whole numbers between -2,147,483,648 and +2,147,483,647</td>
</tr>
<tr>
<td>Integer</td>
<td></td>
<td>Whole numbers between -32768 and +32767</td>
</tr>
<tr>
<td>Byte</td>
<td></td>
<td>Whole positive numbers between 0 and 255</td>
</tr>
<tr>
<td>Type</td>
<td>Single</td>
<td>Double</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Any number to 7 significant figures up to ± 3.402823*10^{38}</td>
<td>Any number to 15 sig figs up to ± 1.79764313486231*10^{308}</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type</th>
<th>Single</th>
<th>Double</th>
<th>Date/Time</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>General</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Both date &amp; time - eg 25/12/98 16:25:08</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Long/Med/Short Date</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Dates: eg 25 December 1998 or 25-Dec-98 or 25/12/98</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Long/Med/Short Time</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Times: eg 16:25:08 or 4:25 (12 hour) or 16:25 (24 hour)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type</th>
<th>Single</th>
<th>Double</th>
<th>Date/Time</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>Currency</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Currency</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Up to 15 figures before dec place, 4 after - eg £1,234.56</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Fixed/Standard</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Numbers with above accuracy - eg 1234.56 or 1,234.56</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Percentage/Scientific</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Ditto but using % or E notation</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type</th>
<th>Single</th>
<th>Double</th>
<th>Date/Time</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>AutoNumber</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Automatic counter - incremented by 1 for each record</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Yes/No</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For data with only 2 possible values</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Yes/No True/False On/Off</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For data with only 2 possible values</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type</th>
<th>Single</th>
<th>Double</th>
<th>Date/Time</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td>OLE Object</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For pictures, sound, video, Word/Excel documents etc</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Hyperlink</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>For links to the WWW or e-mail</td>
</tr>
</tbody>
</table>