Microsoft PowerPoint 2010™
Animating Objects (Level 3)

Contents

Introduction ...........................................................................................................................................1
Animating SmartArt Graphics ...............................................................................................................1
  Animating a Cycle Graphic ...................................................................................................................2
  Animating an Organisation Chart .......................................................................................................3
Animating Charts ...................................................................................................................................5
  Setting Up the Chart .............................................................................................................................5
  Custom Chart Animation .....................................................................................................................5
  Overlaying Charts ................................................................................................................................6
  Animating the Legend ............................................................................................................................7

Introduction

Both text and objects can be animated in a similar way on a PowerPoint slide. You should be familiar with text animation before you work through the examples given here. See the document Animating Text in Microsoft PowerPoint for details. This document covers additional animation effects available for certain non-text objects and ways of creating your own animations, where no built-in ones are provided.

From Microsoft PowerPoint 2007, Microsoft brought in new SmartArt graphics to offer better ways of visually communicating information. In Microsoft PowerPoint 2010, some more SmartArt layouts have been added, and you can convert both slide text (usually a bulleted list) and pictures into a SmartArt graphic. The layouts include graphical lists, process diagrams, organisation or hierarchical charts, and relationships. You can also add visual effects to your SmartArt graphics, shapes, WordArt, and charts, including three-dimensional (3-D) effects, shading, reflections and glows.

Animating SmartArt Graphics

The SmartArt graphics provide various types of graphic that can be added to any Microsoft Office document, including PowerPoint. These include List, Process, Cycle, Relationship, Matrix, and Pyramid graphics as well as Organisation Charts (called Hierarchy from 2007 onwards). When added to a slide in a PowerPoint show, all have built-in animation effects designed specifically for that particular type of graphic. As an example, try out a Cycle graphic.
Animating a Cycle Graphic

1. Start up PowerPoint or, if it is already running, press <Ctrl n> for a new presentation
2. Click on the [Layout] button in the Slides group on the left of the Home tab
3. Click on [Title and Content] in the first row
4. Click where it says Click to add title and type Animating a Cycle Graphic
5. In the middle of the lower placeholder, click on the third icon in the first row for Insert SmartArt Graphic to see the following:

![SmartArt Graphic Selections]

6. Click on [Cycle] in the list on the left then select the second icon in the first row for a Text Cycle – press <Enter> for [OK]

The following skeleton graphic appears, ready for you to type in your data:

![Text Cycle Graphic]

7. Move to the SmartArt Tools Design tab and click on the [Text Pane] button if the pane isn’t showing
8. Type First in the top line in the Text Pane then press <Enter> - an extra placeholder is added
9. Repeat step 8 for 4 more placeholders, typing Second, Third, Fourth and Fifth respectively

**Note:** You can add further placeholders between particular existing ones by pressing <Enter> in the Task Pane (or use [Add Shape] on the far left in the Create Graphic group on the SmartArt Tools Design tab).

To delete the excess placeholders:
10. In the Text Pane, press the <Delete> (or <Backspace>) key to remove them
To setup basic animation:

11. [Close] the text pane on the left (either by clicking on the x or by using the [Text Pane] button in the Create Graphic group on the SmartArt Tools Design tab)

12. Click on one of the arrows to select the whole cycle graphic, then move to the Animations tab and click on the [Add Animation] button in the Advanced Animation group

13. Under Entrance, click on Appear – a number 1 (in a square) should show on the slide indicating the animation effect

If you press <F5> key to run the slide show, you should find that the title is shown first and then (on the next click or <Enter>) the whole cycle is shown as one.

To get the arrows to appear one by one:

14. Click on [Animation Pane] in the Advanced Animation group on the Animations tab

15. Click on the list arrow on the right of the Content Placeholder (there should be only one showing in the Animation Pane) and choose Effect Options...

16. In the Appear window, move to the SmartArt Animation tab and change Group graphic: to One by one

Note: In the Appear dialog box, the Effect tab gives you settings for Sound and After animation. On the PCs in IT Services labs, you may find that the speakers are disabled so you would need to use headphones if you wanted to hear any sound effects. The After animation settings are generally of little use here (if you like, try out the Hide After Animation and Hide on Next Mouse Click effects to see what they do).

17. Press <Enter> for [OK] (note that there are now numbers from 1 to 5 on the slide) then press <F5> to run the show

You should find that the arrows appear one at a time as you press <Enter>.

**Animating an Organisation Chart**

Organisation Charts can be very useful ways of presenting linked data in a presentation. Use this next exercise to create your own Family Tree.

1. Start with a new slide - press <Ctrl m> (or click on the [New Slide] button on the Home tab)

2. Click where it says Click to add title and type Animating an Organisation Chart

3. In the lower placeholder – click on the third icon in the first row of the content icons for Insert SmartArt Graphic

4. In the Choose a SmartArt Graphic window, click on Hierarchy in the list on the left then select the first icon in the first row for an Organization Chart – press <Enter> for [OK]

Your slide should look similar to the following:
5. The top box in the organisation chart is already selected, so just type your **Father’s full name** (pressing <Shift Enter> between his forenames and the family name) - the text size is readjusted as you type.

6. Repeat step 5 typing your **Mother’s full maiden name** (her name before marriage) in the Assistant box, immediately below your father’s box.

7. In the next row down, starting from the left, type in each of their children (i.e., yourself and any brothers or sisters) in the order of their birth.

If there are too many boxes, click towards the edge of each unwanted box in turn and press <Delete>.

If you need extra boxes, click on the rightmost child box, and then click on the list arrow next to the [Add Shape] button in the Create Graphic group on the SmartArt Tools Design tab, and choose Add Shape After.

For everyone in your generation who is married:

8. Click on the box for that person and then click on the list arrow next to the [Add Shape] button and choose Add Assistant.

9. Enter the name of their **husband/wife** in the new box.

You could go on adding further generations below (i.e., your nephews, nieces and own children), if you wanted to, but leave it simple for now.

To animate the organisation chart (make sure it’s selected):

10. Move to the Animations tab then click on [Add Animation] in the Advanced Animation group.

11. Under Entrance, click on **Appear** – a number 1 (in a square) should show on the slide indicating the animation effect.

You should now have a Content Placeholder element, representing the organisation chart, in the Animation Pane on the right (click on the [Animation Pane] button if this is not showing). With the current setting, all the levels of the organisation chart will appear all at once (check by pressing <Shift F5>, if you like).

To get the levels of the chart to appear one at a time:

12. Click on the list arrow attached to the Content Placeholder and choose Effect Options...

13. In the Appear window, click on the SmartArt Animation tab and change Group graphic: to **By level at once**.

14. Press <Enter> for [OK] then use <Shift F5> to run the show from the current slide.

You should find that your father is shown first, next your mother, yourself and any brothers/sisters, and finally the spouses (husbands and wives).

To animate each person individually:

15. Repeat steps 12 to 14, but change Group graphic: to **By level one by one**.

You could also try out **By branch one by one** if you like.

You can easily change the look of your organisation chart with regard to colour and how the boxes look as follows:

16. Make sure your organisation chart is selected by clicking on it and then move to the SmartArt Tools Design tab.

17. Explore some of the different styles provided using the buttons in the SmartArt Styles group.

18. To change the colour of the organisation chart, click on [Change Colours] and choose the colour(s) you want from the examples provided.

19. Run the animation by pressing <Shift F5>.
Animating Charts

Charts also have built-in animation effects, though again you might want to customise these. One annoying feature is that the chart legend isn't also animated - you'll see how to solve this problem later.

Setting Up the Chart

Start with a brand new slide:

1. Press <Ctrl m> for a new slide
2. Click on [Layout] in the Slides group on Home tab and choose [Two Content] in the second row
3. Click where it says Click to add title and type Animating Charts
4. Click in the first placeholder on the left where it says Click to add text and type This slide is to show how to animate a chart
5. Click on the [Bullets] button on the Home tab to hide the bullet

The next step is to create a chart. You could copy a chart into the empty box on the right from Excel, but here, create one within PowerPoint:

6. In the placeholder on the right, click on Insert Chart (the second icon in the first row) - the Insert Chart dialog box appears:

7. A Clustered Column is already selected – press <Enter> for [OK]

This opens up Excel in one half of the screen (with a small datasheet already containing data that has been plotted onto the chart) and PowerPoint on the other half showing the chart on the slide. The data values can be changed but, for this exercise, keep them as they are.

Tip: To change any of the data values or column/row headings, simply overtype what's there. You can resize the data area by dragging out the lower right corner of the range.

8. [Close] Excel (click on the x in the top-right corner) to return to the normal PowerPoint screen

Custom Chart Animation

To add animation to the already-selected chart:

1. Move to the Animations tab then click on [Add Animation] in the Advanced Animation group
2. Under Entrance, click on Appear – the number 1 appears, indicating the animation effect
3. Press <Shift F5> to run the show from the present slide

The title and text appear first then the next click brings up the chart. To get the individual elements on the chart to appear one at a time:
4. Click on the list arrow attached to the Content Placeholder and choose Effect Options...
5. In the dialog box that appears, move to the Chart Animation tab
6. Set Group chart: to By Series then press <Enter> for [OK]
7. Press <Shift F5> to run the show - you will find that the chart grid and legend appear first and then the columns for each series.
8. Repeat steps 4 to 7 but set Group chart: to By Category - the columns appear by category, left to right
9. Again repeat steps 4 to 7 but set Group chart: to By Element in Series (or ... in Category) – each column appears individually one by one

To see how animation works with different chart types, change the type from Column to something else:
10. Click on the chart then move to the Chart Tools Design tab
11. Click on the [Change Chart Type] button on the far left, select a different chart (eg Line) and press <Enter> for [OK]
12. Reset the Effect Options... using the list arrow attached to the Content Placeholder – changing chart type may alter or remove these as different charts have different options
13. Press <Shift F5> to see how different chart types animate
14. Repeat steps 10 and 11, resetting the chart type to a simple Column chart

Overlaying Charts

Sometimes the precise chart animation setting you want isn't available. In such cases you can get round the problem by overlaying one chart with another, with each chart showing exactly what you want. You are going to use this technique to animate the chart legend. First, the chart needs a solid background:

1. Make sure the chart is selected then move to the Chart Tools Format tab
2. Click on the [Shape Fill] button in the Shape Styles group and choose a colour (white is fine)
3. Using the list arrow attached to the Content Placeholder, choose Effect Options... and, on the Chart Animation tab, set Group chart: to As one object and press <Enter> for [OK]
4. Click on the chart background to select the chart then press <Ctrl c> to [Copy] it
5. Now press <Ctrl v> to [Paste] a second copy

You get two charts, almost on top of one another.
6. Click on any of the columns representing the last series (Series 3 in the Legend) to select it
7. Next, click on the [Shape Fill] button on the Chart Tools Format tab and choose No Fill
8. Do the same for the [Shape Outline] immediately below [Shape Fill] choosing No Outline

The column and its legend entry should have disappeared (though the label remains in the legend).
9. Repeat steps 4 to 8, this time removing the next category (Series 2) from the Legend

You should now have a series of graphs, each of which has one less column. Next, these need to be animated. Select each new chart in turn and carry out the following:
10. In the Custom Animation task pane use the list arrow next to the Content Placeholder for element 3 and choose Effect Options...
11. On the Effect tab, set After animation: to Hide on Next Mouse Click – press <Enter> for [OK]
12. Repeat steps 10 and 11 for element 2

You now need to set up the animation order and resize and reposition them:
13. Use the [Re-Order] button at the bottom of the task pane to reverse the order so that the animation begins with one column, with another added each time (ie 3 becomes 1 then 3 becomes 2)
14. Press <Shift F5> to check the order is correct
15. Next, select all three charts using the mouse to drag a selection rectangle over the group – it’s best to do this starting from the bottom of the slide, about a third of the way along.


17. Choose Align Left then click on [Align] again and choose Align Top.

18. Finally, press <Shift F5> to run the presentation.

**Animating the Legend**

Ideally, the legend should be animated so that the new category name only shows when the column is drawn (currently, the column animates but the name is always shown in the legend). To animate this, you have to hide the existing text by changing the font colour:

1. Click on the chart background to select the first chart (element 1).
2. Next click on the legend to select it then on the Series 3 entry.
3. On the Home tab on the Ribbon, change the [Font Color] to match the background (eg white).
4. Repeat step 3 for the Series 2 entry.

You now have to do the same for the second chart (element 2). The problem is getting to it as it is hidden by the first chart. This next sequence of instructions may seem crazy but they do work!

5. Using the <Tab> key, jump between the placeholders on the slide until element 2 is selected (it should also be highlighted in the Custom Animation task pane).
6. Using the <right_arrow> key, jump between the chart elements until the hidden Series 3 entry in the Legend is selected.
7. Repeat step 3 to match the font colour to the background.
8. Finally, press <Shift F5> to view the slide - you should find the legend is also animated.

Though this exercise has probably shown you how difficult it is to create exactly what you want, it should have shown you what is possible (with a bit of effort).

9. End by closing your file (and PowerPoint) – there’s no need to save it unless you want to.