
Using Filters in Microsoft Excel 2003 

 
Introduction 

Microsoft Excel provides a very simple mechanism (autofilter) for selecting 
data subsets. Autofilters can be set up to choose specific values or a range of 
values. Several filters can be used, each acting further on the current data 
subset. An advanced filter is provided for more complicated selections.  

 

Autofilters 

The simplest way to understand how autofilters work is to try them out on an 
example file:  

1. Load up Excel and [Open] the file called phoenix.xls in the D:\training 
folder  

2. Make sure the active cell is within the set of data (eg click on cell A1)  
3. From the Data menu choose Filter followed by AutoFilter  

Filter arrows are now attached to the column headings in row 1. Filtering 
textual data and numeric data is usually slightly different and is dealt with in 
turn below.  

 

Filtering Text 

1. Click on the filter arrow attached to cell F1 and choose Blue-Green  

You now only have the rows whose colour is Blue-Green. Note the row 
numbering down the left hand side of the screen has turned blue, as has the 
filter arrow attached to cell F1. These changes indicate that a filter is in 
operation. Note also that the number of filtered records displayed is shown in 
the bottom left corner of the Excel window - here it says 21 of 50 records found.  

To redisplay all the data:  

2. Click on the filter arrow attached to cell F1 and choose (All)  

http://www.its.rdg.ac.uk/documents/training/excel/inter/phoenix.xls


This first example was very simple; next set a filter for more than one value:  

3. Click on the filter arrow attached to cell G1 and choose (Custom...)  
4. Click on the list arrow attached to the upper box on the right and choose 

BN  
5. Click on the Or option button  
6. Click on the list arrow attached to the lower box on the left and choose 

equals  
7. Click on the list arrow attached to the lower box on the right and choose 

BRV  
8. Press <Enter> or click on [OK]  

Here you have data rows where collector matches either BN or BRV. Note that 
you cannot have more than two matches using autofilter - for three or more 
values you have to use an advanced filter. However, other matching criteria 
(apart from 'equals') may give you the results required:  

9. Click on the filter arrow attached to cell G1 and choose (All)  
10. Click on the filter arrow again and choose (Custom...)  
11. Click on the list arrow attached to the upper box on the left and choose 

does not equal  
12. Into the upper box on the right type *R* (the * is a wildcard, as explained 

on screen)  
13. Press <Enter> or click on [OK]  

Only collectors without an R as an initial are displayed (29 records). You might 
have thought that the R needed to be surrounded by other characters, such 
that collector RFA would have been shown. To see what's gone wrong:  

14. Repeat step 10 and note that Excel has changed the criteria to does not 
contain R  

15. Repeat steps 11 to 13 but this time set a match of ?*R*?    

The ? stands for a single character, indicating that Excel shouldn't apply the 
criteria to the first (or, in this case, last) character in the text. You now have 41 
records, including collector RFA. 

Here's another example:  



16. Click on the filter arrow attached to cell G1 and choose (Custom...)  
17. Click on the list arrow attached to the upper box on the left and choose is 

greater than  
18. Click on the list arrow attached to the upper box on the right and choose 

BRV  
19. Make sure the And option button is set on  
20. Click on the list arrow attached to the lower box on the left and choose is 

less than  
21. Click on the list arrow attached to the lower box on the right and choose 

RFA  
22. Press <Enter> or click on [OK]  

Note that greater than and less than work with words (alphabetically). Only the 
records for collectors CDS and FLC are displayed (BRV and RFA, used in the 
criteria, are not included). Note also the options begins with (and does not 
begin with) and ends with (and does not end with) which work exclusively with 
textual data. Incidentally, you cannot reference a cell or calculate a value in the 
boxes on the right.  

21. Click on the filter arrow attached to cell G1 and choose (All)  

Filtering Numbers 

If you tried to repeat the first exercise on numeric data you would be faced with 
a long list of different values. Here, each number is unique (whereas colour 
can be only one of two values and collector one of five). If you select one value 
from the list you will get just the one row. In these circumstances, you have to 
customise your filter:  

1. Click on the filter arrow attached to cell D1 and choose (Custom...)  
2. Click on the list arrow attached to the upper box on the left and choose is 

greater than  
3. Click in the upper box on the right and type 8  
4. Press <Enter> or click on [OK]  

The 23 records displayed have a diameter value greater than 8. You can find 
data less than a particular value using is less than, or data between two values 
using two criteria and the And option. To find data outside a range the Or 
option must be used:  



5. Click on the filter arrow attached to cell D1 and choose (Custom...)  
6. Check that is greater than 8 is still set and make sure the And option is 

set on  
7. Click on the list arrow attached to the lower box on the left and choose is 

less than  
8. Click in the lower box on the right and type 10  
9. Press <Enter> or click on [OK]  

Only 20 records should now appear - those between 8 and 10. To see just the 
other 30 values:  

10. Click on the filter arrow attached to cell D1 and choose (Custom...)  
11. Click on the list arrow attached to the upper box on the left and choose is 

less than  
12. Turn on the Or option  
13. Click on the list arrow attached to the lower box on the left and choose is 

greater than  
14. Press <Enter> or click on [OK]  

An alternative filter is shown as (Top 10...) - the largest 10 values. Options 
here also let you choose more or less than 10 values, the bottom 10 values, or 
a percentage (eg top 10%).  

 

Multiple Filters 

In the examples to date, a filter has been applied to a single column of data but 
several filters on different columns can be set. With the data still filtered for 
diameter between 8 and 10cm:  

1. Click on the filter arrow attached to cell G1 and choose RFA  
2. Click on the filter arrow attached to cell F1 and choose Red-Brown  

You now have three filters in operation. Each of these can be turned off 
individually by using the filter arrows attached to the heading cells and 
choosing (All). To turn off all filtering in a single step:  

3. Open the Data menu, select Filter then Show All  

 



To turn off the autofilter arrows:  

4. Open the Data menu, select Filter then AutoFilter  

Advanced Filtering 

Advanced filters allow you to construct more complicated filters. They work by 
creating two special cell ranges - one defines the data area and the other the 
filter criteria. The filter criteria can be created anywhere on the spreadsheet, 
but the convention is to place them above the data area (to match autofilter). 
The first step, therefore, is to create space above the existing data:  

1. Drag through row numbers 1 to 5 down the far left-hand side of the 
worksheet  

2. Open the Insert menu and select Rows - 5 blank rows should appear  

Next set up the filter area, in which the column headings are repeated in the 
top row with criteria typed into the rows below.  

3. Click on the 6 of row 6 to select the row of column headings  
4. Click on the [Copy] button (or use Copy from the Edit menu)  
5. Click in cell A1 and press <Enter> to [Paste] in the headings  
6. Click in cell F2, type Blue-Green and press <Enter>  

You now have a very simple filter set up - one matching the first autofilter 
example. To run it: 

7. From the Data menu choose Filter followed by Advanced Filter...  
8. Set up the List Range: as A6:G56 and the Criteria Range: as A1:G2  
9. Press <Enter> or click on [OK] to carry out the filter  

Having seen how advanced filtering works, here's a more complicated example. 
Each row in the criteria range can be set up to give a particular criterion 
(similar to the Or option you met earlier), while within each row, more than one 
test can be applied (equivalent to And).  

10. Click in cell D2, type >8 and press <Enter>  
11. From the Data menu choose Filter followed by Advanced Filter...  



12. Press <Enter> or click on [OK] to run the filter - the List and Criteria 
ranges are the same  

13. Next, click in cell D3 and type <8  
14. Click in cell F3, type Red-Brown and press <Enter>  
15. From the Data menu choose Filter followed by Advanced Filter...  
16. Amend the Criteria Range: to A1:G3  
17. Press <Enter> or click on [OK] to carry out the filter  

You now have rows where the diameter value is less than 8 and the colour 
red-brown plus rows with the diameter more than 8 and the colour blue-green. 
This couldn't be achieved using autofilter.  

If you need to find data between two values in an advanced filter then you 
have to duplicate the column heading concerned. Again, it's easiest to see how 
this works by carrying out an example:  

18. Click on cell D1 and [Copy] the column heading  
19. Click on cell H1 and press <Enter> (for [Paste]) to duplicate the heading  
20. Click in cell H3 and type >7.5 - press <Enter>  
21. From the Data menu choose Filter followed by Advanced Filter...  
22. Amend the Criteria Range: to A1:H3  
23. Press <Enter> or click on [OK] to carry out the filter  

The result gives you rows where the diameter value is between 7.5 and 8 and 
the colour red-brown plus rows with the diameter more than 8 and the colour 
blue-green (as before).  

Warning: It's very easy when using advanced filters to forget to redefine the 
criteria area.  

24. Drag through cells D3 to H3 and press <Delete> to clear the red-brown 
criteria  

25. From the Data menu choose Filter followed by Advanced Filter...  
26. Press <Enter> or click on [OK] to carry out the filter  

You will find you have ALL the data records displayed. This is because the 
filter is still set up to use row 3, which is now empty - ie include any records!  

 

 



Using Multiple Sheets

With an advanced filter you can set up criteria on a different worksheet from 
the data, and show the results on the separate sheet if you want. Here, you 
need to create a new sheet before you can start:  

1. Open the Insert menu and choose Worksheet  
2. Click on the PHOENIX tab, drag though row numbers 1 and 2 and click on 

[Copy]  
3. Click on the new Sheet1 tab, make sure you are in cell A1 and press 

<Enter> for [Paste]  
4. Click on the PHOENIX tab, drag through row numbers 1 to 5, from the 

Edit menu use Delete  
5. Click on the Sheet1 tab (you must start the filter from the sheet where you 

want the results to appear)  
6. From the Data menu choose Filter followed by Advanced Filter...  
7. To set the List range: click on the PHOENIX tab and type in A1:G51 (ie 

PHOENIX!A1:G51)  
8. Set the Criteria range: to A1:G2  
9. Under Action turn on the Copy to another location option  
10. Set Copy to: to A5 and press <Enter> or click on [OK]  

You will find the filter is carried out on Sheet1, with the original data still intact 
on PHOENIX.  

 

Exercises 

This exercise uses the file advanced.xls which is available on IT Services PCs 
in the D:\training folder.  

Once the file is loaded, move to the students tab.  

1. Filter the data to find out how many students have Foot as their tutor. 

2. How many of tutor Smith's students live in Private accommodation? 

3. How many students live in a Hall of Residence (ie not Private 
accommodation)? 

4. How many students are called Claire or Clare? 

http://www.its.rdg.ac.uk/documents/training/excel/advanced.xls


5. Filter the data to show only the students who have one or more middle 
initials. 

6. Filter the students to show just those whose surname begins with S. 

7. How many students came in 2005 (as shown in their userid by 05)? 

8. How many overseas students are female? 

9. Filter the students to show the 12 oldest. 

10. Using an advanced filter, filter the data to show both male students living in 
Bridges Hall and unmarried female students living in Wessex Hall. 

11. List the overseas students who are taking option 2, 4, 6 or 8. 

12. Filter the students to show all those with a birthday in April. (if you don't 
know how dates are stored and used in formulae, work through the notes on 
Dealing with Dates and Times in Excel). 

Hint: you will need to create a new column of data using the Month function. 

Try to amend this to show all those students with a birthday coming up later 
this month. 

Hint 1: you will need to create another new column using the Day function. 

Hint 2: a criteria such as <30 can be entered directly into a cell; if it has to 
be calculated then use =">"&xxx where xxx could be a cell reference or 
function, for example. 

Close the file by clicking on the [Close Window] button - if you want to keep 
the results do so when asked. 

Answers to filtering exercises

 

 

http://www.its.rdg.ac.uk/documents/training/excel/filters
http://www.its.rdg.ac.uk/documents/training/excel/filters/answers.htm
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