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1. Introduction 

1.1 The four parts of this guide 

This guide is intended primarily for scientists who wish to use GenStat for the analysis of 
climatic data.  Our primary aim is to teach GenStat, rather than statistics, hence minimal 
information is given regarding the data and the interpretation of the results. 

The version of GenStat described here is the Eleventh Edition for PCs under Windows 98, ME, 2000, 
XP or Vista. The minimum recommended configuration is a Pentium PC with 32 Mb RAM.  

Part I of this guide is an introductory tutorial.  It covers GenStat’s facilities for simple data entry and 
analysis and introduces descriptive statistics and simple inference (t-tests and simple regression).  
Part II describes GenStat’s facilities for the summary and presentation of climatic data.  We use 
examples of monthly and daily data.  Part III introduces GenStat’s facilities for regression analysis.  
This is followed by chapters that describe some further facilities for processing climatic data, 
including the fitting of distributions, and multivariate analysis. 

GenStat is a Windows package and we assume that users have some experience of working in a 
Windows environment.  However, GenStat can also be used by giving commands, and, for users who 
wish to proceed further, we have a chapter entitled – Moving from menus to commands in Part IV 
of the guide.  The menus are based on an underlying command language, which is available for non-
standard analyses. This language is common to all versions of GenStat, including those on 
workstations and mainframes. 

The final chapter in Part IV is on developing a strategy.  This covers three topics.  The first is on the 
data and includes the use of ODBC for data transfer.  The second is on software and considering how 
GenStat might fit into a software strategy and lists some alternative packages.  The third is on staff, 
and includes ideas for training. 

GenStat1  is developed by VSN International Limited, 5 The Waterhouse, Waterhouse Street, Hemel 
Hempstead, Hertfordshire HP1 1ES, UK.  

1.2 Use of this guide 
One purpose in writing this guide is to provide supporting material for those, who are on a training 
course.  This guide, particularly the first part, may also be used for self-study, either within a 
supervised environment, or for users who have experience of other statistical packages.  This guide is 
not intended for self-study by beginners to statistical computing. 

We find typically that Part I (Chapters 2 – 6) takes between one and three hours for those familiar with 
other statistical software.  Thus the key elements of Part I could be covered in a half-day session of a 
training course.  This would introduce the software and could include a discussion on initial 
impressions of GenStat at the end of the session.  In general, the use of modern statistics packages 
has helped training courses considerably.  It is now possible even for short courses to concentrate 
primarily on ideas of climatic analysis.  Previously a much greater proportion was often devoted to 
mastering the software. 

Most real datasets are much larger than those used in the Introduction.  Hence, in Part II, we are 
particularly concerned with ways of organizing and presenting the types of data that are often used in 
the analysis of climatic data. 

                                                 
1 GenStat is distributed by VSN International Limited, 5 The Waterhouse, Waterhouse Street, Hemel 
Hempstead, Hertfordshire, HP1 1ES, UK. Tel: +44/0 1443 450230, Fax: +44/0 870 1215653 – 
www.vsni.co.uk e-mail: support@vsni.co.uk. GenStat is the registered trademark of VSN International 
Limited.    
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Many studies involve looking at “relationships”.  In statistical packages this is mainly handled by the 
regression facilities and hence we introduce those in Part III.  We then introduce other facilities in 
GenStat for processing climatic data.  We choose methods that are important in their own right, but 
also aim for users to gain sufficient confidence that they can look for additional facilities, when they 
are needed.  Resource people may wish to read through this part of the guide when preparing a 
training course.   

All datasets used in the examples and exercises can be found on the CD.  If you read this manual in a 
printed or pdf version, the files can be downloaded from The University of Reading website 
(http://www.rdg.ac.uk/). 

1.3 Acknowledgements 
The structure of this guide and part of the materials have been adapted from the guide called “Using 
GenStat for Windows, 5th Edition, in Agriculture and Experimental Biology”.  This was prepared by 
staff from the SSC, Reading and ICRAF, Nairobi.  It was, in turn based on original notes, prepared by 
Gillian Arnold, from the University of Bristol. 

We are very grateful to the many people who contributed to earlier versions of this guide.  We also 
appreciate the permission from the Zimbabwe Meteorological Services to use their detailed data in 
this guide.  We also acknowledge the other Met Services that have allowed us to use their data. 

We also wish to acknowledge the efforts of the GenStat development team, who were prepared to 
add further facilities to this version of GenStat, mainly for those involved in climatic analysis.  These 
included particularly the topics described in Chapter 15, on extremes and directional data. 

We are also most grateful to the UK Met Office, who have funded the preparation costs of this guide, 
and VSN who funded the update to Version 11. 

 
Roger Stern James Gallagher 
Statistical Services Centre  Statistical Services Centre 
University of Reading University of Reading 
Harry Pitt Building Harry Pitt Building 
Whiteknights Road Whiteknights Road 
Reading RG6 6FN Reading RG6 6FN 
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2. GenStat basics  

This part of the guide is written in the form of our introductory tutorial.  The aim is for the 
user to become familiar with the basic operations of GenStat for Windows. 

If you are following the chapter while using GenStat then we indicate where you should 
type something with a ⇒.  The remaining text describes what is being done. 

In this guide, we sometimes assume a user already has experience of Excel.  We show how data 
entered into Excel can be analysed with GenStat and also how data from GenStat can be saved as 
an Excel file. 

Users who are not familiar with Excel should omit these sections. Experience with Excel is not 
necessary for using GenStat. 

2.1 Starting GenStat 11th Edition 
You start GenStat within Windows on a PC by clicking on the GenStat icon on the desktop or toolbar 
or by selecting “GenStat 11th Edition”, from the Programs Menu.  If no GenStat icon is available on the 
desktop, you can create one yourself2. 

After starting GenStat, you see a standard Windows interface with a title bar, menu bar, tool bar, 
status bar and several windows, Fig. 2.1a.  The Output window will contain the output from the 
operations we perform.  The input log keeps a record of what has been done in an analysis.  Many of 
the menus are standard for Windows applications. Only Run, Data, Spread, Graphics and Stats are 
GenStat-specific. 

                                                 
2 By default, GenStat is installed in the folder C:\Program Files\Gen11Ed. Use Windows Explorer and 
go to the subfolder Gen11Ed\bin. Right click with the mouse on Genwind11.exe and create a 
shortcut. This shortcut can now be dragged onto the desktop. You might rename the icon on the 
desktop (right click and click ‘rename’) as GenStat 11th Edition, to avoid confusion with previous 
versions. 
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Fig. 2.1a  GenStat Windows 

 
Fig. 2.1b shows an example of the interface after a spreadsheet has been opened. 

Fig. 2.1b  Windows ⇒ Tile Vertical 

 

2.2 Data input 

2.2.1 Data input using the Spread Menu 
⇒ We show two ways to enter data into GenStat.  The first is within GenStat.  Choose Spread ⇒ 

New ⇒ Create. 

Status bar 

Input log 

Output 
Window 

Toolbar

Menu bar
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Fig. 2.2a  Spread ⇒ New ⇒ Create Fig. 2.2b  Specify the size 

⇒ Choosing Create brings up a box allowing you to specify how many data columns you want, 
and how many rows of data there will be.  Edit the box to make a GenStat spreadsheet with 11 
rows and 2 columns as shown in Fig. 2.2b. 

Different types of spreadsheet can be made, but the default (i.e. what GenStat will select in the 
absence of further information) - Vector - is usually the type you will need.  
⇒ Click [OK], and an empty spreadsheet will appear. You can start to enter data by clicking in a 

cell in the spreadsheet. Type the number, and then press the [Enter] key. Enter the following 
numbers into the first column: 

1330 2094 1851 1470 1557 1932 1184 2452 1347 1792 1488 

⇒ Press the [Enter] key after the last number. The cursor will then move to the top of the next 
column. Enter these numbers into the second column: 

120 161 150 142 152 155 126 183 132 167 149 

Make sure that you press the [Enter] key after typing the final number. The resulting sheet is shown 
in Fig. 2.2c.  If you have made any mistakes, these can be easily corrected, using the arrow keys to 
move to the cell to amend and entering the correct value. 

For each row, the value in the first column is the annual rainfall total, and the value in the second 
column is the number rain of days. It is helpful to give the columns more meaningful names than the 
default C1, C2, etc.  
⇒ To give a name, position the cursor as shown Fig. 2.2c.  It becomes a pencil, rather than a 

hand, and clicking on the mouse gives a popup screen where you can type the name for the 
column, as shown in Fig. 2.2d.  Then press [OK]. 
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Fig.  2.2c  Naming C1 Fig. 2.2d  Giving the name 

 
 

⇒ Once you have given column C1 the name total, repeat with C2 with the name raindays. These 
names now appear on the columns of the spreadsheet. 

2.2.2 Organising the Windows 

It is useful to decide how you wish to use the different windows in GenStat.   
⇒ Use Window ⇒ Tile Vertically to give the layout with the three Windows namely the Output, 

the Input Log and the Spreadsheet.  This is roughly as shown earlier in Fig. 2.1b.   

These windows indicate one difference between most statistics packages, like GenStat, and 
spreadsheets, like Excel.  With a spreadsheet you have effectively one type of window within which 
you can have your data and results. 

In GenStat you have one window for your data and this is called the spreadsheet.  It does not include 
any results. 

You have a separate window, called output, for the results. 

You also have here a third window called the Input Log, see Fig. 2.1b.  This keeps a record of what 
you have done. 
⇒ Now minimize the Input Log and then use Window ⇒ Tile Vertically again (or press 

<Shift><F4>) to give the layout roughly as in Fig. 2.2e. 
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                         Fig. 2.2e  Windows ⇒ Tile vertically (with Input Log minimised) 

                
 

⇒ Now try maximizing the output window, and then reducing it to its half size again. 
⇒ Then use Window ⇒ Tile Horizontally. 

Which layout of the windows do you prefer? 

2.2.3 Saving the file 
⇒ Use File ⇒ Save As and save the file as cmtut1.gsh, as shown in Fig. 2.2f. 

Fig. 2.2f  File ⇒ Save As 
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⇒  Use Run ⇒ Restart Session, so you are ready to try the second way of entering data.  It will 
warn you, as shown in Fig. 2.2h, but persevere by clicking on ‘Yes’. 

Fig.2.2g  Run ⇒ Restart Fig. 2.2h Accepting the restart 

If you are not experienced in computing, or if you are not familiar with Excel, then go to Section 2.3. 

2.2.4 Data input from Excel worksheets   

This section assumes you are familiar with Excel. If not, or if you are using different 
spreadsheet software, then omit this section and go to Section 2.3. 

Most of your data is probably entered already, in a database or in a spreadsheet like Excel. Importing 
data into GenStat is easy. 
⇒ Minimize GenStat and go into Excel. 

We assume you are now in Excel.   
⇒ Create a new Excel workbook and enter the same data as earlier, see Fig. 2.2i.  In the cells 

above the data, you can enter the names for the columns: ‘total’ and ‘raindays’. 

      Fig. 2.2i  Data entry in Excel 

 
⇒ Save your Excel workbook and give it the name cmtut1.xls.  You have now finished with Excel, 

so minimize Excel and go back to GenStat. 
⇒ In GenStat, choose File ⇒ Open and select the Input file. Indicate that the file to import is of 

the ‘Other Spreadsheet Files’ type as shown in Fig. 2.2j. 
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Fig. 2.2j  Look for Excel file Fig. 2.2k  Use first sheet 

 

 

 
⇒ In the next window, you can select which worksheet of the workbook you want to import. In this 

case just click Finish to import the data into a GenStat spreadsheet. 

In this example the data were easy to import, because the Excel sheet only included what was to be 
imported.  To import any set of data equally easily, into GenStat, from Excel, you can define a named 
range in Excel.  
⇒ Go back into Excel and add a line or two of description as shown in Fig. 2.2l.  Then, in Excel, 

highlight the range containing the data and the header row and On the Formulas tab, in the 
Defined Names group, click Create from Selection, see Fig. 2.2m  (If you are using a 
version of MS Excel that precedes the 2007 edition choose Insert ⇒ Name ⇒ Define 
instead). 

Fig. 2.2l  Excel file with description Fig. 2.2m  Defining a name in Excel 

 
 

⇒ Give the range a name, for instance Data, as shown in Fig. 2.2n.  Then save the Excel file and 
minimise Excel. 



2 – GenStat Basics Analysing climatic data using GenStat for Windows 

12 

Fig. 2.2n  Specifying the name of the range as “Data” 

 
 

⇒ Go back to GenStat and restart the session by selecting Run ⇒ Restart Session and then 
clicking [Restart], to clear all windows, dialogue boxes and the spreadsheet.  When you now 
reopen the file cmtut1.xls, you are able to select the range Data as shown in Fig. 2.2o.  The 
R:Data in Fig. 2.2o signifies that you are using a named range. 

 

Fig. 2.2o  Importing the named range into GenStat 

 
 

An alternative way of transferring the data is to copy a range of cells from Excel and paste it into 
GenStat.  This is not considered good practice in data management, as will be seen in Chapter 18, 
but is a fast and easy way of data transfer for a quick provisional analysis.  

⇒ To show this way, choose Run ⇒ Restart Session to clear all data out of GenStat.  Go back 
into Excel.  Highlight the range containing the data and column headers and from the Home 
tab choose Copy, or right click with the mouse in this range and click Copy.  Now the data are 
loaded into the Windows clipboard.  Go back to GenStat and choose Spread ⇒ New ⇒ From 
Clipboard, see Fig. 2.2p and the data are entered into a GenStat spreadsheet. 
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Fig.2.2p  GenStat option to import from the clipboard 

2.2.5 Advanced data input 

It is also possible to import data from other file formats or to create links with other files. More 
information can be found in Section 18.3, where we show how to establish an ODBC link. 

2.2.6 Leaving GenStat 
⇒ To end a GenStat session, choose File ⇒ Exit. You will be asked if you want to save any of 

the open windows or spreadsheets. Select [Yes] to save the spreadsheet, but [No] for the 
other windows , and [Exit] GenStat. 
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As well as showing you how to enter data into GenStat, you have seen how easy it is to 
transfer data from another package, such as Excel. So, if you are already familiar with a 
spreadsheet or another statistical package, using GenStat does not have to stop you 
from using other software.  You can use GenStat in addition.  We will show examples 
from Excel spreadsheets at various points in this guide. 

2.3 Some basic data manipulation 

2.3.1 Summary statistics 
⇒ Restart the session and reopen the file cmtut1.gsh.  The data in the spreadsheet are passed 

into the GenStat server as soon as you click anywhere outside the spreadsheet or the spread 
menu.   

⇒ Try doing this by clicking in the output window. 

Some summary information about the two columns total and raindays will appear in the output 
window showing minimum, mean and maximum values, number of values and number of those that 
are missing. What are the values for these two variates? 
⇒ For further statistical summaries use the Stats menu, as shown below.  Choose Stats ⇒ 

Summary Statistics ⇒ Summarize Contents of Variates.  Select the variates required in 
the resulting dialogue shown in Fig. 2.3b, and then click [OK]. 

 

Fig. 2.3a  Choosing the dialogue Fig 2.3b  Selecting the columns 

 

⇒ Select the Output Window.  If you cannot see this window, try clicking the  or  buttons 
in the tool bar successively until it appears. Some of the results are shown in Fig. 2.2c.   There 
are other statistics available with the same dialogue box.   
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Fig. 2.3c  The results 

 
 

⇒ Find the Summarize contents of Variates dialogue again.  Click on the [Defaults] button to 
clear all currently selected statistics.  Reselect the variables and choose Arithmetic Mean and 
Standard Deviation. Then press the [More statistics] button and choose Standard Error of 
Mean, and click [Run]. 

⇒ Use Graphics ⇒ 2D Scatter Plot and complete the dialogue box as shown in Fig. 2.3e. 
 

Fig.2.3d Choosing the scatter plot 
dialogue  

Fig.2.3e  Specifying the y and x 

 
 

 

The relationship between the total rainfall and the number of rain days is as follows: 



2 – GenStat Basics Analysing climatic data using GenStat for Windows 

16 

Fig. 2.3f  The graph is in its own window 

 
 

⇒ Close the graph window with File ⇒ Exit (choosing [No] to the question about saving the 
graph), and then close the 2D scatter plot and summary dialogue boxes by choosing [Cancel]. 

 

Many dialogue boxes in GenStat do not close when you click [OK]. They only close if 
you click on [Cancel]. This is so you can easily repeat an operation, or get more output 
from the current analysis without having to go back through the menus. It is quite easy to 
get a large number of windows and dialogue boxes open at once, so it can be quite hard 

to find the one you are looking for.  Clicking the  or  buttons in the tool bar can 
help find the one you want.  Alternatively, to find a particular dialogue or menu box, just 
repeat the menu commands that opened it (e.g. Graphics ⇒ 2D Scatter Plot) as this 
will bring back the box complete with anything that had been entered. It is a good idea to 
close a box by clicking [Cancel] as soon as it is no longer needed. 

2.3.2 Calculating and formatting columns 

It is easy to calculate new variates from those already entered.  In this example, it would be 
interesting to find the mean rain per rainday in each year. This is simplest to do within the 
spreadsheet.  
⇒ First, the spreadsheet needs to be selected. Do this, either by clicking somewhere in it (if you 

can see it), or use the toolbar arrow buttons or the Window menu, as shown in Fig. 2.3g. 
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Fig.2.3g  Selecting the spreadsheet 

 
 

⇒ To calculate a new column, choose Spread ⇒ Calculate ⇒ Column as shown in Fig. 2.3h.  
 

Fig. 2.3h  Choosing the calculate dialogue 

 
 

 
Fig. 2.3i  Giving the formula Fig. 2.3j  The results 



2 – GenStat Basics Analysing climatic data using GenStat for Windows 

18 

⇒ Complete the box as shown in Fig. 2.3i.  The calculation can either be typed into the top box, 
or you can use the mouse to click on the operator buttons and double click on the variates as 
required.  

Type the name of the new column into the bottom box labelled Save Result In, Fig. 2.3i.  Then click 
[Run].  Click [Cancel] after this to remove the dialogue box. 

There is now a new variate, called meanperday, added to the spreadsheet, as shown in Fig. 2.3j, 
which holds the 11 values of the mean rain per rain day.  The name is part shaded (in yellow on a 
colour screen) to indicate that the column meanperday is a calculated column.   
⇒ To illustrate the difference between an ordinary and a calculated column, try to change a value 

in the meanperday column.  GenStat gives a warning, see Fig. 2.3k. 
 

Fig. 2.3k  Showing that the column was calculated 

 
 

Thus GenStat's spreadsheet is a little like an ordinary spreadsheet in that it records the 
calculation, rather than just doing the transformation.  If you change a value in the 
original column, the derived values do not, however, change automatically.  You could 
then use Spread ⇒ Calculate ⇒ Recalculate, to update the derived values. 

Fig.2.3j  Commands keep a record of your work 

 
 

You may have noticed that commands have been appearing in the Input Log as you 
work. This is a record of what you have done, written in the GenStat command language. 
You can re-run any of these commands with the Run menu, or copy them into a new 
window to make a program.  There are already some examples on page 20. More 
information can be found in Chapter 16.  To understand for instance what has happened 
within GenStat, when you did the last calculations, we have shown the output window in 
the figure above. There you see, in line 40, that the spreadsheet generated a command 
font command, that was executed by the GenStat Server. Line 41 shows that the results 
were then passed back to the spreadsheet. (Ignore the large number there, 22238896, 
which may well be different when you run the commands. It is an internal reference 
number so GenStat knows which spreadsheet contains the new column.) 
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Calculations will normally be done in a spreadsheet as above. Once you become 
experienced in using GenStat, you could alternatively do calculations only in the GenStat 
server, using the Data ⇒ Calculations menu, rather than the Spread ⇒ Calculate ⇒ 
Column route that you used above. The result is the same to the GenStat Server, but 
you would not automatically see the calculated column in a spreadsheet. 

In the spreadsheet, each value of meanperday is displayed to four decimal places. 
⇒ You can change this with Spread ⇒ Column ⇒ Attributes/Format, Fig. 2.3m.  Make sure 

that you select meanperday in the column box. A faster way is to right-click in the meanperday 
column and to choose the Column Attributes option. The same Column Attributes Dialogue 
Window will appear.  

⇒ Type ‘1’ in the Decimals box Fig. 2.3n, and check that Fixed is now the numeric format. You 
may also wish to enter a concise explanation of the contents of the column in the Description 
box.  Now, whenever meanperday is printed in the output, it will be displayed with 1 decimal 
place by default.  Click [OK] to effect the change. 

 

Fig. 2.3m  Choosing the Format dialogue Fig. 2.3n  Give the column one decimal place 

 
 

Assume that these data values came from 11 years in order. It would be useful to have this 
information entered too.   
⇒ Click in the first column (total) of the spreadsheet.  Choose Spread ⇒ Insert ⇒ Column 

before Current Column.  This gives a dialogue box called Create a new column as shown 
in Fig. 2.3o. 

Fig. 2.3o  Spread ⇒ Insert ⇒ Column Fig. 2.3p  Right-click and choose Fill 
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⇒ Type year in the name box and click on [OK].  A new column will appear in the spreadsheet 
filled with missing values (denoted by *), Fig. 2.3p.   You could now type in the numbers 1 to 
11, or the real years, if they are known, but there is a quicker way to fill in regular sequences.  

⇒ Right click in the Spreadsheet and choose Fill from the popup menu as shown in Fig. 2.3p or 
choose Spread ⇒ Calculate ⇒ Fill.  In the Fill dialogue, shown in Fig. 2.3q, make sure that 
year is in the top box.  Clicking [OK] will fill year with the numbers 1 to 11. Fill can also be 
used to make patterned sequences.  

⇒ Details of the use of this, or any other dialogue, can be found by clicking the [Help] button in 
the dialogue box. An example is given in Fig. 2.3r.  

 

Fig. 2.3q  Complete dialogue Fig.2.3r  Try the Help button 

 
  

⇒ Try plotting the mean per day against the year as a line graph.  Use Graphics ⇒ 2D Line Plot 
⇒ SingleXY type with meanperday as the Y and year as the X.   

Now investigate the graph.  What is the year with the lowest mean? Is there any obvious pattern? 
⇒ Remember to close the graph with File ⇒ Exit at the top of the graph. 

2.4 Factor Columns 

2.4.1 Introducing factors 

So far, all the information entered into GenStat has been numerical. It is possible to include textual 
information as well. One structure that accepts this kind of information is a factor. This is a special 
column used to indicate groups in the data.  

Four years in this data set were El Nino years, the second, third, eighth and tenth.  The remainder 
were ordinary years. So we will make the factor with two groups or levels, and here, one is labelled E 
and the other O.  
⇒ Click in the first column of the spreadsheet (year) and choose Spread ⇒ Insert ⇒ Column 

after Current Column.  Type the name type into the Name box, and click to select Factor 
under Column Type in Fig. 2.4a.  The dialogue will change.  

Fig. 2.4a  Spread ⇒ Insert ⇒ Column 
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⇒ Specify that the factor has 2 levels and then click on the [Labels] button. The dialogue shown 
in Fig. 2.4b appears. Type 'E' and press the [Enter] key. The next level (2) will become 
selected. Type 'O', press [Enter] and then click [OK] to make the changes take effect. 

⇒ Click [OK] in the Create a new column dialogue, as shown in Fig. 2.4a to make the new 
column, which contains empty cells. 

 

Fig.2.4b  Add labels to the factor Fig. 2.4c  Entry of data 

 
 

⇒ Now type the following values into the new column, as shown in Fig. 2.4c. 

  O  E  E  O  O  O  O  E  O  E  O 

If you make a mistake by typing lower case 'e' instead of an upper case 'E', GenStat will 
turn it into an upper case 'E'; if you type the wrong letter, GenStat will give you a 
message and ask you to retype your entry.  Double clicking gives a pop-up menu, as 
shown above, which lists the allowable levels.   

 

⇒ The factor column can be used to label a graph. Choose Graphics ⇒ 2D Scatter Plot.  Fill in 
the boxes as in Fig. 2.4d, and click [Finish] to produce the graph shown in Fig. 2.4e.  If you 
first click [Next], you can add titles to the graph and the axes. 

Fig. 2.4d  Graphics ⇒ 2D Scatter Plot 
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Fig. 2.4e  Resulting graph 

 
 

By using the Edit ⇒ Edit Graph once you have the graph, or right clicking in the graph, you can 
choose to edit the Axes key or other commands.  They can be used to modify the layout of the graph 
until it is ready for reporting or publishing. Graphs can be saved in different formats by choosing File 
⇒ Save as see Fig. 2.4f.  You leave the GenStat Graphics Window by choosing File ⇒ Exit from the 
menu bar. 

Fig. 2.4f  File ⇒ Save As, choosing and emf type 

 
 

Back in the spreadsheet, the column called type can be modified to display longer labels.   
⇒ Select the type column in the spreadsheet.  Right click and choose Column Attributes.  Click 

the [Labels] button, and edit the labels (to be El Nino and Other), making sure that you press 
[Enter] after typing each new label.  Click two [OK] buttons when you have finished, and the 
labels in the variety column should now be modified.  

Alternatively, the full labels could have been entered when the factor was first created. You would still 
have been able to enter the values into the column by typing E or O only, the first letter of the labels. 

Earlier, you used Stats ⇒ Summary Statistics ⇒ Summarise Contents of Variates to give some 
summaries of the data.  Now, with the data in two groups, it is useful to give the summaries for each 
group individually.  The dialogue used earlier can be used for this, but a more general alternative is: 
⇒ Stats ⇒ Summary Statistics ⇒ Summaries of Groups (Tabulation), Fig. 2.4g. 
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Fig. 2.4g  Stats ⇒ Summary ⇒ Tabulation Fig. 2.4h  Results 

⇒ Complete the dialogue as shown and press [Run].  The results are shown in Fig. 2.3h in the 
Output Window. 

2.4.2 Saving data 

Before continuing, save the spreadsheet. 
⇒ Choose File ⇒ Save as. By default, a Window appears suggesting you save the data as a 

GenStat spreadsheet (*.gsh).  A wide range of other file formats is also available. 

Fig. 2.4i  File ⇒ Save As, then change to Excel 

 

In Section 2.2 we showed how data could be imported from an Excel worksheet or could be entered 
directly in GenStat using the Spread menu. We had imported the file cmtut1.xls from Excel and have 
modified it. If you change the format in the figure above, and specify an Excel file then, when you try 
to save, you get a warning message. 
 

Fig. 2.4j  GenStat warning that the original file will be replaced 
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2.4.3 Deleting data  

In this section we will delete the column, called meanperday, that has been generated.  We also show 
the difference between deleting a whole column and deleting its contents.   
⇒ First select the column meanperday. Then click in the name field (or press <ALT><Ctrl>C, or 

use Spread ⇒ Select ⇒ Current Column).  Clicking again will deselect the column.  Practice 
selecting and deselecting columns.  Finishing with the meanperday column selected. 

⇒ Once selected, you might think that the <Delete> key should delete the column.  Press the 
<Delete> key.  This deletes (as expected), but just the data.  The column remains!  Use Edit 
⇒ Undo to get the column back.   

⇒ What you need to do is to delete the whole column.  The column should still be selected. Use 
Spread ⇒ Delete ⇒ Current Column.  You may wish to practice this.  If so, use Edit ⇒ Undo 
and try again.  You can also select one, or more, rows and delete them in the same way.   

2.4.4 Available variables 
⇒ You can check which variables are currently available to the GenStat server using Data ⇒ 

Display or pressing the F5 key, see Fig. 2.4k and Fig. 2.4l. 
  

Fig.2.4k  Display Dialogue Fig. 2.4l  Information about the current variables 

 

 
 

This lists the names of the structures and their types. All structures used so far are 
variates (meanperday, raindays, total and year) and factors (type), but later on you will 
use other types of columns too.  This is also a useful dialogue box from which you can 
delete columns when they are no longer needed. 
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2.5 Understanding how GenStat works 

2.5.1 A first introduction to the GenStat command language 

Although in Chapter 2.1, we mentioned that GenStat is basically a standard Windows application, the 
truth is a bit more complex. Before the Windows version you could use GenStat as long as you knew 
the "language". You simply typed commands, which you submitted to GenStat.  

GenStat 11th Edition is indeed a Windows application, but the menus are based on an underlying 
command language.  You can still use GenStat by typing commands in the Input Window as we show 
now. At the same time, we show how GenStat may be used as a calculator. 
⇒ Restart GenStat.  Use File ⇒ New and choose the Text Window, Fig 2.5a.  This gives you an 

Input Window.  In this window, type Print 3+4 as shown in Fig. 2.5b. 
 

Fig.2.5a  File ⇒ New Fig. 2.5b  Complete the text window 

  
 

⇒ Now select the Run menu as shown in Fig. 2.5c. You can choose either Submit Line (if the 
cursor is still on the line you typed) or Submit Window. Choose one of these. 

 

Fig.2.5c  The Run menu Fig. 2.5d  Results 

 

 

 

You have now submitted your "program" of commands to the GenStat server. The results are put in 
the Output Window, see Fig. 2.5d.  

You can go to the output window in various ways, e.g. by using the Windows menu.  There you see 
that GenStat normally "echoes" the command and shows you that 3+4=7. 



2 – GenStat Basics Analysing climatic data using GenStat for Windows 

26 

An alternative to typing the command is to use the Data menu Data ⇒ Calculations, see Fig. 2.5e.  
This gives the dialogue shown in Fig. 2.5f. 
 

Fig. 2.5e Choose the dialogue Fig. 2.5f  Another way of calculating 

 
 

Then type 3 + 4 as the function, click on Print in Output and then on [OK]. If you look in the Output 
window, you see that 3 + 4 still equals 7! 

Fig. 2.5g  3 + 4 is still 7! Fig.2.5h  The Input log 

 

⇒ The Input Log Window is also useful.  It keeps a record of all the commands you have 
submitted.  Access it by Window ⇒ Input Log.  You see that the use of the Calculation menu 
has resulted in GenStat preparing the commands PRINT 3+4 for you and has submitted them 
to the GenStat server. 

So, that is how GenStat works. You prepare commands, which are submitted to the GenStat server. 
The Windows version has simply given you a variety of ways to prepare the commands for GenStat. 
GenStat obeys the commands and puts the results in the Output Window. It keeps a record in the 
Log Window. 

If the commands produce graphs, then GenStat puts the graphs in a Graphics Window.  If you make 
a mistake in the command, it prints an error message in the Fault Window (and in the Output 
Window).  
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The example above (3 + 4 = 7) indicates that GenStat may be used as a simple calculator. This is 
worth a little practice.  It is useful to have a scientific calculator.  Also it is sometimes useful to 
transform data.   
⇒ For example, if you want to calculate the difference between 4.35 and 2.37 expressed as a 

percentage of 4.35, open the calculator with  Data ⇒ Calculations, check that Print in 
Output, is still ticked and type the following calculation in the top box: 

 100 * (4.35 -2.37) / 4.35 

⇒ Click [OK]. This will give the following in the output window: 

  (100*(4.35- 2.37))/ 4.35 

    45.52 

i.e. the difference is 45.52% of 4.35. 

It is important that the brackets () are included where appropriate to make sure that the calculation 
you are trying to do has only one meaning.  

The symbols +, -, *, / are used for the operations of addition, subtraction, multiplication and division 
respectively and ** is used for powers.  There are also various mathematical functions available.  One 
is for calculating the square root of a number.  The function is SQRT(), where the number whose 
square root is required is given in the parenthesis, for example SQRT(12.37).  Fig. 2.5i gives an 
overview of how to perform some calculations by using the Input Window.  More information can be 
found in the GenStat Help file under ‘List of functions for expressions’. 
⇒ Try more calculations to see how all this works, using both an Input window and the Data ⇒ 

Calculations dialogue box.  Some examples are given below. 
 

Fig.  2.5i  Some basic calculations using the Input Window 
Symbol Operation Example Result 
+ addition PRINT 3+4 7.000 
- subtraction PRINT 3-4 - 1.000 
* product PRINT 3*4 12.00 
/ division PRINT 3/4 0.7500 
** exponentiation PRINT 3**4 81.00 
Function Operation Example Result 
SQRT(x) Square root PRINT SQRT(4) 2.00 
EXP(x) Exponential function PRINT EXP(1) 2.718 
LOG(x) natural logarithm of x, for x > 0 PRINT LOG(2.718) 0.9999 
LOG10(x) logarithm to base 10 of x, for x > 0. PRINT LOG10(10) 1.000 
ROUND(x) rounds the values of x to the 

nearest integer. 
PRINT ROUND(1.2345678) 1.000 

Other examples 
PRINT (1/2) 0.5000 
PRINT (100*(4.35 -2.37))/4.35 45.52 

2.5.2 Server sessions 
⇒ After the above calculations, the Input and Output Windows look a mess. All the data can be 

cleared out of the GenStat server with Data ⇒ Clear All Data or Run ⇒ Restart Session.  
Less drastically, you can ‘clean up’ the output window by clicking the ‘Clear Output’ button 

( ) in the toolbar. 
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3. Simple statistical inference 

In the analysis so far, we have just considered descriptive statistics. Thus we have 
summarised the data numerically and drawn graphs. In this example, we introduce ideas 
of simple statistical inference. We take an example from Mead, Curnow and Hasted, 
(2003) pages 33-34 and 38-39. This compares wheat yields for 6 farmers where there 
was a new system of giving agroclimatic advice, compared to 10 farmers, who used 
standard information.  The yields, in tons per hectare, were as follows: 

new:  2.5  2.1  2.4  2.0  2.6  2.2 

standard: 2.2  1.9  1.8  2.1  2.1  1.7  2.3  2  1.7  2.2 

3.1 The use of boxplots 
⇒ Because these columns are of different lengths, they are entered into two separate 

spreadsheets. For the first set, use Spread ⇒ New ⇒ Create as shown earlier in Chapter 
2.2.1  Set it to have 1 column of 6 rows, enter the data as shown in Fig.3.1a and give the 
column the name new. 

⇒ Save the spreadsheet, giving it the name cmtut2.gsh (see Chapter 2.3.4) if you need 
instructions on saving).  Then use Spread ⇒ New ⇒ Create again.  Change the number of 
rows to 10 and enter the second set of data into this other spreadsheet, naming the column as 
standard, see Fig. 3.1b.  Save the spreadsheet, giving it the name cmtut3.gsh. 

 

Fig. 3.1a  1st sample Fig.  3.1b  2nd sample Fig. 3.1c  Graphics ⇒ Boxplot 

 

 

 
 

⇒ One way to present the data is to use a boxplot. Use Graphics ⇒ Boxplot, complete the 
dialogue as shown in Fig. 3.1c and click [Finish].  This gives the display shown in Fig. 3.1d.  
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Fig. 3.1d  Resulting graph Fig. 3.1e  Changed  

 

One use of boxplots is to show outliers.   

⇒ Go back to the spreadsheet and insert a value of 2.9 instead of 2.0 for the 8th value in the 
Standard group.  The general shape of the graph is the same, but the odd value is indicated as 
deserving close scrutiny. 

⇒ There are two ways of displaying the boxplot. Use Graphics ⇒ Boxplot and click [Next].  You 
can now choose between two types: Box and Whisker, Fig. 3.1f and Schematic, Fig. 3.1g. Try 
both, as shown below. The advantage of a schematic boxplot is that you can easily discover 
outliers. 

Fig. 3.1f  Box and Whisker plot 

 

 

 median 

 first quartile 

third quartile 

  minimum value 

maximum value 
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Fig. 3.1g  Schematic boxplot 

 

In a Box and Whisker boxplot, the ends of the whiskers mark the minimum and maximum 
values of the data set, in a schematic boxplot they mark the ‘upper and lower inner 
fences’. The upper inner fence is defined as the upper quartile plus 1.5 times the 
interquartile range, or the maximum value if that is smaller. The lower fence is defined 
similarly.  

Extreme values between 1.5 and 3 times the interquartile range (plus the upper or minus 
the lower quartile) are by default marked as green crosses. More extreme values (more 
than 3 times the above mentioned range) are marked as red crosses. 

 

⇒ If you made this change, then set the edited value back to 2.0, in the spreadsheet before 
continuing. 

3.2 Comparisons of means 
⇒ Simple comparisons of the means of two different samples can be made with Stats ⇒ 

Statistical Tests ⇒ One and two sample t-tests.  Complete the dialogues as shown in Fig. 
3.2a and 3.2b. Use the Options button in Fig. 3.2a to give the dialogue in Fig. 3.2b.  

 

Fig. 3.2a  Stats ⇒ Tests ⇒ One and Two Sample Fig.  3.2b  Options sub-dialogue 

 

upper inner fence 

third quartile 

median 

  first quartile 

lower inner fence 

 outlier 
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The output window shows the results, see Fig. 3.2c. 

Fig. 3.2c  Output from the t-test dialogue 

 
 

 

3.2.1 Some more data manipulation: appending spreadsheets  

In the 2-sample example that was used for the t-test, the data were put into separate 
spreadsheets. Data often need reorganizing before analysis and here this step is 
illustrated by joining the data together for the two sets.  Fig. 3.2f shows what we are 
aiming for. 
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Fig. 3.2d  1st set Fig. 3.2e  2nd set Fig.  3.2f  Stacked data 

 

 

 

What we wish to do is to append the data from the two columns and add a further 
column that specifies from which set each observation has come.  

⇒ If the spreadsheets are no longer in GenStat then they will have to be opened.  They were 
saved earlier with the names cmtut2.gsh and cmtut3.gsh, see Fig. 3.2d and 3.2e. 

⇒ Click in the shorter spreadsheet cmtut2.gsh, so it is the active window. Use Spread ⇒ 
Manipulate ⇒ Append and complete the dialogue as shown in Fig. 3.2g.  This appends 
cmtut3.gsh to the data in cmtut2.gsh and adds the information for a factor that distinguishes 
between the two groups.  Press [OK].  

 

Fig.  3.2g  Spread ⇒ Manipulate ⇒ Append (with cmtut2.gsh as the active window) 
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The layout of the data shown in Fig. 3.2f is more common and is used in most of the 
remainder of this guide. 

⇒ Rename the column new in the long spreadsheet to yield.  
⇒ Use File ⇒ Save As to save the spreadsheet, giving it the name cmtut4.gsh. 

3.3 References 
Mead, R., Curnow, R. N. and Hasted, A. M. (2003) Statistical Methods in Agriculture and 

Experimental Biology, 3rd edn. Boca Raton: Chapman & Hall/CRC Press. 
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4. Simple regression 

4.1 Setting up the data 

We now introduce some key elements of data analysis, by means of simple regression.  
This example is taken from pages 178 - 181 of Mead, Curnow and Hasted (2003).  We 
will return in Chapter 11 to the more general use of GenStat for regression. 

 

⇒ Use Run ⇒ Restart Session to start a new job.  Accept the option [Yes] to proceed.  
 

Fig. 4.1a  Restart again Fig.  4.1b  Accept the warning 

 

 
 

 

 

 

⇒ Use Spread ⇒ New ⇒ Create and make a spreadsheet with 2 columns and 17 rows as 
shown in Fig. 4.1d. 

 

Fig. 4.1c  Create a new sheet Fig.  4.1d  Sheet with 17 rows and 2 columns 

 

⇒ Enter the data and name the two columns as shown in Fig. 4.1e: (See page 7 for instructions 
on naming columns, if necessary.) Save the data giving the file the name cmtut5.gsh. Click 
outside the spreadsheet to transfer the data to the GenStat server.  This gives some summary 
statistics for each of the two columns.  
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⇒ Choose Stats ⇒ Summary Statistics ⇒ Summarize Contents of Variates and specify 
some summary statistics as described in Section 2.3.1. 

 

Fig. 4.1e  Regression data Fig.  4.1f  Produce some descriptive statistics 

 

 

 

⇒ Choose Graphics ⇒ 2D Scatter plot… and complete the dialogue as shown in Fig. 4.1g to 
give the scatterplot.  

 

Fig. 4.1g  Graphics ⇒ 2D scatter plot Fig.  4.1h  Results 
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4.2 Correlation and regression 
⇒ Choose Stats ⇒ Summary Statistics ⇒ Correlations and complete the dialogue as shown 

in Fig. 4.2a to give the correlation between uptake and conc.  You should find a value of 0.984. 
 

Fig.  4.2a  Stats ⇒ Summary ⇒ Correlations 

 
 

⇒ Choose Stats ⇒ Regression Analysis ⇒ Linear models, Fig. 4.2b, and complete the 
dialogue as shown in Fig. 4.2c.   

 

Fig. 4.2b  Regression dialogue Fig.  4.2c  Specify the x and y 

The results are in the output window and are given in full in the regression section of this guide.  They 
show the fitted equation is: 

   uptake = -2.043 + 0.02494 * conc 
⇒ Return to the regression dialogue to give a plot of the fitted line.  Click on [Further Output] 

then [Fitted Model], to give the plot shown in Fig. 4.2e. 
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Fig. 4.2d  Further output sub-dialogue Fig.  4.2e  Fitted model 

 

 
 

⇒ Repeat the steps to get the [Further Output] dialogue again and select [Model Checking].  
Accept all the defaults by pressing [OK]. In the Graphics Window, 4 plots will be shown as in 
Fig. 4.2f. 

Fig. 4.2f Model checking 

 
This example should have shown it is easy to “do statistics” once you have become familiar with the 
use of dialogues in GenStat.  This allows training courses to concentrate on statistical concepts.  The 
computing has become easy. 
 

4.3 A GenStat tutorial 
GenStat includes its own tutorials as part of the software.  Use Help ⇒ Tutorial and try the one 
called Linear Regression.  If you find it helpful then try some of the other tutorials. 
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5. Review of Chapters 2–4 
Here we review some of the tasks you have undertaken in the tutorial. Could you? 

 Task Hint 

1 Open a set of data you entered into Excel, for example the 
file cmtut1.xls? 

 

See page 12 

2 Enter a new set of data that has 3 columns and 6 rows? 

 

See page 6 

3 Save the data in a GenStat spreadsheet to a disc?  See page 9 

4 Import a named range from an Excel worksheet. See  page 12 

5 Derive a new column containing the square of the values 
in an existing column? 

See page 18 

6 Find the names and lengths of all the columns of data. See page 24 

7 Summarise data in two columns by giving a boxplot? See page 28 

8 Explain why a boxplot is often a useful summary of a set 
of data and also to compare different sets?   

See plot on page 30, look in a 
statistics book, or ask 
someone.3 

9 Give a line plot?   See dialogue on page 15   You 
did not do a line plot but it is 
another option on the graphics 
menu. 

10 Summarise a column of data? See page 14 and page 22 

                                                 
3 This tutorial is to teach GenStat, rather than statistics. 
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 Task Hint 

11 Explain the use of the Input Log Window? See page 26  

12 Explain how GenStat “works”? See page 26 

13 Explain what is meant by a factor column using the 
example in the third spreadsheet on page 32 

See page 20 

14 Make an existing column into a factor column?   See the pop-up menu on page 
20  

15 Organise the Windows to show just the spreadsheet 
and output windows horizontally. 

See page 8 

16 Leave GenStat? If not, then keep practicing! 
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6. Challenge 1 – Easy use of GenStat 

Open the file called cmtut1.gsh again.  Mark the columns giving the rain days, the total, 
and the type of year, in that order.  Now right-click on the mouse to give the popup menu 
shown in Fig. 6.1a. 

 

Fig. 6.1a  Quick analysis 

 
 

When you use the menu to give a 2D scatter plot you will probably get the dialogue for 
the 2D scatter plot, so all you have to do is to press Finish. 

Try more of the Analysis and Graph options on the Quick analysis menu in Fig. 6.1a.  
For example what do you get with the same column still marked if you use Analysis ⇒ 
Tally? 
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7. Before starting the analysis 

In this chapter we look first at the way the data are set-up for the analysis.  In most 
studies the time-consuming tasks are primarily concerned with data manipulation, rather 
than analysis.  Hence we describe the facilities for manipulation in this chapter. 

We will use a simple example of monthly data, but the concepts apply equally to daily 
records, synoptic data, upper air, and so on.   

7.1 Examining the data 
In this chapter we mainly use an example of monthly data. They are the monthly rainfall totals for 33 
years, from 1950 to 1983 (omitting 1956 and 1957) at Galle, in Sri Lanka. We assume that the initial 
calculations to produce these monthly summaries were done elsewhere.  In Chapter 9, we show that 
GenStat can be used to produce these summaries. 

Use File ⇒ Open and open the file called genrain.xls.  Part of the data is shown in Fig. 7.1a.  
 

Fig. 7.1a  Monthly rainfall data (with bookmarks) 

 
 

Climatologists emphasise the importance of data scrutiny and the data above are in colour for the 
maximum and minimum value each month.  We see, for example, that there were 47 mm in the driest 
May, and 590 mm in the wettest. To produce bookmarks, such as those shown above, use Edit ⇒ 
Bookmark ⇒ By Value.  Then select all the months and use the option, shown in Fig. 7.1c, to mark 
the minimum and maximum.  A variety of other criteria are also possible. 
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Fig. 7.1b  Bookmarks dialogues Fig.  7.1c  Add bookmarks 

 
 

Sometimes it is useful to reorganise the data into a single long column.  This can be done using 
Spread ⇒ Manipulate ⇒ Stack.  Complete the dialogue as shown in Fig. 7.1e.  You wish to stack 
12 columns, i.e. all months.  Mark the 12 columns in the ‘Available Data’ field, i.e. everything except 
the Year and move them into the ‘Stack Columns’ field.  Do the same with the ‘Year’, but move it 
into the ‘Repeat Column’ field.  Say you want the resulting factor column to be called ‘Month’ and 
that you want to use the names from the columns to label the month factor. Finally rename the 
stacked column to be ‘Rain’. 
 

Fig.  7.1d  Stacking data Fig.  7.1e  Stacking 12 columns 

 
 

The resulting spreadsheet, Fig. 7.1f, is the new ‘shape’, but is not quite as we would like.  We first 
move the year column to be the first in the new spreadsheet.  This is simply done by positioning the 
cursor so it becomes a hand, as shown in Fig. 7.1f.  Then the mouse can be used to slide the column 
as you wish.  An alternative is to use Spread ⇒ Column ⇒ Reorder.  Following this step, either 
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right-click to give the pop-up menu or use Spread ⇒ Sort, or <Ctrl> <F9> and sort on the year 
column.  This gives the data, in time-series order, as shown in Fig 7.1g. 

Fig.  7.1f  Moving  Fig. 7.1g  Sorting 

  
 

We now continue our examination of the data. Use Graphics ⇒ Boxplot to give the dialogue shown 
in Fig. 7.1h.  At the top of this dialogue we see the question ‘How are the data organized?’  The first 
alternative, called ‘List of variates’ corresponds to the way we had the data originally, while the 
second corresponds to the single long column we have just produced. 
 

Fig. 7.1h  Graphics ⇒ Boxplot Fig.  7.1i  Schematic boxplots 

 
 

Complete the dialogue as shown in Fig. 7.1h and click ‘Finish’.  The results are given in Fig. 7.1i.  If 
you do not get the same type of picture, then return to the dialogue, click ‘Next’ and then use the 
option for a ‘Schematic’, rather than a ‘Box and Whisker’ plot.   

The main features of the resulting graphs are that there is rain throughout the year, but 
the main seasons, in April/May and October/November are clear.  The data are 
reasonably symmetrical, but there are 9 values that are marked separately as being out 
of the ordinary.  For example the 712 mm in July 1953 is particularly high, given that 
most of the years have less than a third of this value. 
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A rugplot is an alternative to the boxplot.  This is shown in Fig. 7.1j and also gives the same options 
for the layout of the data. The resulting plot is in Fig. 7.1k. 

Fig. 7.1j  Graphics ⇒ Rugplot Fig. 7.1k  Resulting graph 

 
 

These graphs are called ‘exploratory’, because they are intended to support the scientist in examining 
the data.  The alternative is presentation graphics, intended for readers of reports.   

7.2 Repeated measures 

In the next two sections we compare the two alternative layouts of the data that were 
mentioned above.  The first we call ‘repeated measure’ and the second ‘time series’ for 
reasons that we explain below. 

The two layouts of the monthly data, used in Section 7.1, are shown in Figs. 7.2a and 7.2b. 
 

Fig.  7.2a  Repeated measures layout Fig. 7.2b  Time series:layout 

      
 

To relate to statistics books and other areas of application, we consider the general issues that can 
guide the user on which layout might be appropriate for a given analysis.  The first issue is the ‘unit’ 
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that is used.  In the first layout, Fig. 7.2a, the ‘unit’ is a year, and we have made 12 measurements in 
each year.  These are sometimes called ‘repeated-measures’, because we are measuring the same 
unit repeatedly in time. 

Repeated measures occur in many areas of application of statistics.  For example, in a health study, 
we may weigh the same person on repeated occasions.  In forestry, we measure the girth of a tree 
each time. In a livestock study we measure milk yield repeatedly on each animal. 

In the ‘time-series’ layout, shown in Fig. 7.2b, the ‘unit’ is a month, and we just have a single 
measurement each month.  This is the same layout as we would have if the data were a monthly 
economic index, for which we wish to do a time-series analysis. 

In climatology, both layouts are useful, depending on the objectives of the study.  We now consider 
the use of the ‘repeated measure’ layout in more detail.  Having the year as the unit, is also useful if 
we interpret the value for a given month as one ‘index’ of the year.   Then we have a total of 12 
indices and more can be calculated and then analysed. 

As examples, we calculate the seasonal and annual totals from the data.  An example of the calculate 
dialogue is in Fig. 7.2c and the results are in Fig. 7.2d.  We have here defined Winter to be the three 
month period from January to March, and so on. 

 

Fig.  7.2c  Spread ⇒ Calculate ⇒ Column Fig.  7.2d  Quarterly and annual values 

  
 

This layout also makes it easy to give simple time-series graphs, as shown in Fig. 7.2f.  We will see, 
in the regression chapter, Chapter 11, that it is equally easy to fit a trend line to the data. 
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Fig. 7.2e Graphics ⇒ Line plot Fig.  7.2f  Time-series graph 

 
Sometimes care must be taken, because of the circular nature of the data.  In this example the year 
goes round in a circle, while for synoptic data the day may be the circle.  For example when 
calculating the seasonal summary, how would you calculate the winter rainfall, if November to 
February is defined as the winter season?  In terms of the calculations in Fig. 7.2g, it is not quite  

  Winter = Jan + Feb + Nov + Dec 

This is because you usually need the January and February values that follow December, while this 
calculation will give you the preceding ones. 
 

Fig. 7.2g  Using the SHIFT function Fig. 7.2h  Sub-dialogue for the functions 

 
 

The calculation is not difficult, once the complication is recognised, because GenStat, like Excel, has 
a wide variety of functions that can be used in calculations.  In the Spread ⇒ Calculation ⇒ Column 
dialogue, in Fig. 7.2g, you either have to know that the ‘Shift’ function exists, or click on the 
‘Functions’ button, and use the sub-dialogue given in Fig. 7.2h. 

In Fig. 7.2g we have given the calculation as  

  Winter2 = shift(Jan+Feb;-1) + Nov + Dec 

It could equally be given as 
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The full "program" is in Fig. 16.3a.  Do not type it yet.  We will produce it in stages. 

 

Fig. 16.3a  A simple program in GenStat 

 

Before starting, press  to clear the Output Window.  Then use File ⇒ New ⇒ Text window to 
open a new input window. This is where you will type the commands.  

Type the first three lines, as shown in Fig. 16.3b. 
 

         Fig. 16.3b  First commands to type                        Fig. 16.3c  Second group to add 

                 
 

Do not forget to type the colon (:) on the last line. Then press  or use Run ⇒ Submit Window to 
submit these commands to GenStat.  If this gave any errors, then correct them and run the 
commands again. 

Now add the second group, as shown in Fig. 16.3c.  Run the whole set of commands so far, by 

pressing . This clears the output Window before running the commands, so you can see the 
results clearly.  Correct any errors if you made them. 

 

 

Of course GenStat can only detect errors in the "syntax". So, if you typed RAED instead 
of READ, then it will be an error. It cannot detect if a number was typed incorrectly. This 
must be checked against the original data. GenStat does try to help by printing summary 
values in the Output Window.  
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You have probably typed at least one value in error, because we have given 2.9 to type above, for the 
8th value in the second group, when it should have been 2.0.  Correct this mistake and run again.  It 
remains to type the last two lines of the "program". Type just the first of these lines, i.e.  

append [newvector=all ; group=type] new , standard 

With the cursor still on the line, use Run ⇒ Submit line. Correct if there were mistakes.  Notice that 
this is a command that does not produce results in the output window.  It will tell you, however, if you 
have made a mistake. 

Instead of typing the last line directly we will practice using GenStat's dialogue to give the structure. 
Use Stats ⇒ Statistical Tests ⇒ One and two-sample t-tests. Complete the dialogue as shown 
and click on Run. 

Fig. 16.3d  Using a dialogue to generate the commands 

 
 

Now go to the input log.  The last line is shown in Fig. 16.3e. 
 

Fig. 16.3e  Command generated by t-test dialogue 
TTEST [PRINT=summary,test,confidence,variance; METHOD=twosided;\ 
GROUPS=type; CIPROB=0.95; VMETHOD=automatic; NTIMES=4999; SEED=0] Y1=all 
 

As already mentioned, using the GenStat menus generates much longer commands in the Input 
Window than is usually needed.  Copy this line into your input window. Edit it so it reads 

TTEST [GROUPS = type; ciprob = 0.95 ] all 

With the cursor still on the line, use Run ⇒ Submit line. Correct if there were mistakes. Save the 
program file. Call it cmprog1.gen. 

Previously we saved files with the extension .gsh because they were in GenStat’s spreadsheet 
format.  Here we use the extension .gen because they contain GenStat commands.  You should now 
have a "program" where each section has been tested.  

It is time to test the whole program.  Restart GenStat using Run ⇒ Restart Session.  

Then load the file called cmprog1.gen and run the whole program by selecting Run ⇒ Submit 
Window 

It now just remains to see how GenStat responds when you make mistakes. If you have already 
made, and corrected many mistakes, that is fine. Otherwise now is the time to make some. These can 
be spelling mistakes, or grammatical errors, like swapping a comma and a semi-colon. 
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Make just one mistake at a time, because GenStat does not always behave sensibly after the first 
mistake. 

To conclude this section we review the concepts that have been introduced. 

You prepared the program in a special input window. You can also type commands into 
the output window, for example the input log. But this confuses the function of these 
windows and we suggest that you normally use a special input window, as here. 

The program was prepared and tested in small parts. We think that this is a useful 
routine. Even if you write, or are given, a long program, unless it works first time, split it 
into small sections, to check that each part runs successfully, before running the whole 
program. GenStat has the facilities to encourage this, with its Run ⇒ Submit Selection 
menu. If there are mistakes in one section, then do not proceed to the next section until 
they are corrected. GenStat often ignores further commands after a mistake has been 
detected. 

The program began with the JOB command. This is the equivalent of the Data ⇒ Clear 
All Data menu option and ensures that a complete run of the program starts without 
columns in GenStat's memory. 

16.4 The syntax of GenStat's commands 

All GenStat's commands, also called statements, have the same "syntax". That is, they 
obey the same grammatical rules. In this section we explain these rules. This 
explanation should enable you to read any GenStat program and also to make full use of 
GenStat's Help facilities. 

It is important for everyone to realize that you need to understand the “grammar” of a 
language, if you are to use the language effectively.  This applies to ordinary languages, 
like English or Swahili and also to computer languages.  One difference is that people 
are forgiving of those who make mistakes when starting to use the language, but the 
computer is not.  So any error, such as a comma, where a semi-colon was expected, will 
not work. 

Those who are “skimming” can proceed to Chapter 16.5. 

 

We begin with some familiar examples of GenStat's commands 
 

TTEST [ciprob = 0.95] new; standard 
TTEST [groups = type; ciprob = 0.95] data 
PRINT structures = block, treat, yield; dec = 0, 0, 2 
 

There are three components to explain: the name, the options and the parameters. 

1. The name of the command.  

In the examples above, these are TTEST and PRINT and they tell GenStat what sort of action is 
required.  These names can be given in capital or lower case letters.  

2. The option list associated with a command.  

This is in square brackets; for example, the first TTEST command includes one option, namely 
[ciprob = 0.95]. The second TTEST example includes two options, namely [groups = 
type; ciprob = 0.95]. If there are no options then you can omit the square brackets 
completely. 
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3. The parameter list associated with a command.  

For example, the PRINT command  

PRINT structures = block, treat, yield; dec = 0, 0, 2 

above has 2 parameters, the first specifies the structures upon which operations are to be 
performed, i.e. what to print.  The second parameter gives information for each structure, i.e. 
how many decimals to use for each column printed.  We will see below that this command can 
be given in a simpler form as  

PRINT block, treat, yield; dec = 0, 0, 2 

(Note that the word PRINT shows that GenStat started in the era when all results were 
automatically sent to a printer. Now a better name for the command would be DISPLAY, 
because the results are normally displayed in the output window.) 
 

It is important to know when to use a comma and a semi-colon in a command.  When any option or 
parameter has more than one item, a comma separates the items in the list. So, in the PRINT 
command above, where we refer to 3 columns, the command is given as: 
PRINT block, treat, yield         i.e.  
PRINT block [comma] treat [comma] yield           
When a command (or directive) includes more than one option or more than one parameter, then a 
semi-colon is used to separate them. For example: 

PRINT structures = block, treat, yield; dec = 0, 0, 2  i.e. 

PRINT structures = block, treat, yield [semi-colon] dec = 0, 0, 2 

normally shortened to 

PRINT block, treat, yield; dec = 0, 0, 2  

Each command or procedure has a list of allowed option and parameter names. You can see what 
they are by looking at the Help associated with the command, see Fig. 16.1i for the HEATUNITS 
procedure.  There are various ways to get Help and here we look for the help on DESCRIBE.  One 
method is as follows.  Type DESCRIBE at the beginning of a line in any window.  Then press the [F1] 
key.  This should take you straight to the Help on DESCRIBE.  An alternative is :  Help ⇒ Reference 
Manual ⇒ Procedure Library.  A PDF will open in a new window. Details of the DESCRIBE 
procedure can be found on page 250.  Alternatively, go to the corresponding dialogue, which is Stats 

⇒ Summary Statistics ⇒ Summarise Contents of Variates.  Click on the  (Help) button.  

From the Help for DESCRIBE you will see that it has 3 possible options, namely PRINT, SELECTION 
and GROUPS and it also has two possible parameters, namely DATA and SUMMARIES. 

The DESCRIBE command was used (from the menus) in the introductory tutorial, see Section 2.3.1.   
If you use the default selections, as shown in Fig. 16.4a… 
 

 

 

 

 

 

Fig. 16.4a  Describe dialogue with default output 
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…it is equivalent to typing the command: 

DESCRIBE  data = total, raindays 

If you specify a selection of descriptive statistics, then it might result in the command. 

DESCRIBE [selection = mean, median] total, raindays 

Now we describe how to give options or parameters. The general rules apply consistently to any 
option or any parameter for any command.  The normal format is name = list of things, for example 
with the DESCRIBE command we used data = total, raindays. There is also selection = mean, 
median. We use selection = mean, median to explain the structure further. 

The name, i.e. selection, is one of the permitted option words - see the Help for DESCRIBE. It can 
be written in upper or lower case and can be abbreviated as long as it is unambiguous. So it could be 
written as sel =    or even s =   .  

After the = sign we give the list of summary statistics that are recognised by the command. For the 
DESCRIBE command there are 22 possible summaries, of which mean and median are two. These 
words can again be shortened, as long as GenStat can work out what they are. So sel = mea, med is 
acceptable.  If you give a word that GenStat does not recognise, then an error is generated. For 
example DESCRIBE [sel = mean, standev] cluster, fruit would be an error, because the GenStat 
word for the standard deviation is sd, not standev. 

Now look at the parameter for the DESCRIBE command, i.e. DESCRIBE data = cluster, fruit. The 
name of the parameter, data can be abbreviated, and as it is the first parameter that is permitted for 
this command, it can even be omitted completely. So the command could be given simply as  
DESCRIBE total, raindays 

For the data parameter, the permissible list for data is the set of columns that are available. These 
names cannot be abbreviated.   

In giving commands, extra spaces can be inserted to help make a command readable.  If 
you need to use more than one line for the same command, then use the continuation 
character \ at the end of each line to be continued.  

 

For example type and run the commands shown in Fig. 16.4b. 
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Fig. 16.4b  Commands to input and display a matrix 

 
 

Finally we explain the difference between options and parameters. The first parameter is special.  
Take the PRINT command below.  The first parameter says what structures will be displayed. The 
decimal parameter then says how many decimals will be displayed for each of the 3 columns. So the 
decimals list of 0,0,2 is "in parallel" to the list of column names, i.e. block, treat, yield. For example  

PRINT block, treat, yield ; dec = 0,0,2,4,1,2,1,0 

would not be sensible.  GenStat would give a warning, and would then ignore all the decimal settings 
after the third. 

Options, on the other hand, always apply to the command as a whole. 

DESCRIBE [selection = mean, median] cluster, fruit 

So the option to give the mean and median applies to both columns.  If you wished to give the mean 
for the first column and the median for the second, you would have to give the command twice, i.e. 
DESCRIBE [sel=mean] cluster 
DESCRIBE [sel=median] fruit 

16.5 Examples of GenStat programs 

You have already seen a simple “complete” program in Fig. 16.3a.  In Chapter 16.5.1 
and 16.5.2 we describe a more useful program.  We calculate the dates of the start of 
the rains, repeating the work we did in Section 9.5, where we had to use a whole 
sequence of menus.   

In Chapter 16.5.3 we generalize the commands by adding a “loop”.  This will then 
process the data for 4 different definitions of the start, in one go.  This enables us to 
automate repetitive analyses.  For example we could similarly analyse the data for 
different stations. 

Putting commands together in this way could be called a “program”.  We describe the 
next stage in Chapter 16.5.4, and that is to turn the command into a “procedure”.  You 
have already seen procedures in this chapter when, in Fig. 16.1e you chose an example 
to illustrate the DAYLENGTH procedure.  Once a procedure has been written it can be 
used just like any other command in GenStat.  With a procedure, you add an extra word 
that GenStat understands, and we explain why this is useful. 

Finally, in Chapter 16.5.5 we demonstrate how to make procedures visual by creating 
menus and dialogues for them. We provide two examples of a user procedure and show 
how to create a custom dialogue for each one. 

Those of you who are just “skimming” should still read 16.5.1.  There we emphasise that 
it is easy to use a program that someone else has written, and this is itself very powerful.  
Then proceed to the next chapter. 
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16.5.1 Using a program 

In Fig. 16.5a we show a set of commands that we have written. There we open a data file containing 
daily rainfall data, and calculate the date of the start of the rains, for the same definition that we used 
in Chapter 9.5.  This is the first occasion after 1st October that the 3-day rainfall total exceeds 20mm. 

These commands have been saved in a file called start.gen.  In other chapters we have saved data 
files, such as the Zimbabwe data and given them names like zimdata.gsh.  Here the file contains 
commands, rather than data, so we use a different extension. 
 

Fig. 16.5a Commands to calculate the dates of the start of the rains 

 
 

In order to run the commands, save the data file “zimdata.gsh” into the same directory that you are 
using for your current GenStat work.  Then use Run ⇒ Submit File as shown in Fig. 16.5b.  This 
opens the dialogue shown in Fig. 16.5c, into which you type your input file name.   
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      Fig. 16.5b Submitting the file                            Fig. 16.5c The Submit File dialogue 

         
 

Click on Run to execute the commands.  One output is a graph, shown in Fig. 16.5d, which indicates, 
for example, that the median starting date was after about 60 days.  The year is assumed to start on 
1st September, so this is the beginning of November.  The season always started by the end of 
November as 100% of start days occurred before day 90. 

 

Fig. 16.5d Part of the results from the file of commands 

 
 

This method of running a file of commands is particularly useful if you want to call GenStat from 
another piece of software.  You could then use GenStat for the analysis, and return to your software 
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with the results.  If you need further information then look at the help for GenBatch, for which the first 
few lines are shown in Fig. 16.5e. 
 

Fig. 16.5e Help information about using GenStat in batch mode 

 
 

Here we are within GenStat, and so there are simpler ways of running the commands in Fig. 16.5a.  
Use File ⇒ Open and open the file called start.gen. Then use the option Run ⇒ Submit Window to 
process the data. 

Once you have opened the file, you could change the commands if you wished.  In this section we do 
not assume that you will write this sort of program, or even understand every command.  But still you 
could probably change it.  For example, the definition was the first occasion that 20mm was 
exceeded.  Could you find the line where this is specified, and change it to 15mm or 25mm, if that 
were more appropriate? 

Or the line that specifies the data file is as follows: 
import 'zimdata.gsh'  

To analyse the data from another station, the name of the file is all that need be changed. 

We claim that it is usually quite easy to follow roughly what a program is doing, and to change it 
slightly.  This is already a powerful skill. 

This skill indicates how much the use of statistics packages has changed, with the Windows-style 
interface.  Earlier you had to learn how to write commands, before you could start analyzing your 
data.  Now we have reached Chapter 16, before we need to consider commands in any detail.  And 
you can still proceed, by learning how to read, and edit, before you learn to write. 

Those who are skimming, can now proceed to the next Chapter. 

16.5.2 Writing your own programs 

We now assume that you would like to understand the program shown in Fig. 16.5a sufficiently that 
you could then write some programs of your own.  It is at this point that you may suddenly experience 
some pain.  This will remind you that GenStat used to have a reputation for being difficult to learn.  

You can get some guidance from GenStat Help. Go to Help ⇒ Contents and Index and expand 
GenStat Command Language. In particular, look at the topics under Commands by 
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language, such as Input and output (as shown in Fig 16.5f), Data structures and Calculation 
and manipulation. 
 

Fig. 16.5f GenStat guide on the command language: Information on Input and Output   

 
 

It is usually the organization of the data and results that is more difficult than the analyses, and there 
are already plenty of examples on different analyses.  You may also find further information on the 
GenStat web site, which is at http://www.vsni.co.uk/software/GenStat/. 

There is a payoff.  The pain is not just to make you suffer, but is related to the power of the system.  
We look briefly at some examples from the program in Fig. 16.5a, and we start by avoiding the pain.  
The last 5 lines are as follows: 
 

CALC startday=ndayinyear(startdate;9) 
PRINT yr, startdate, startday 
DESCRIBE startday 
TALLY [graph=%cum] startday 
FSPREAD yr, startdate, startday 
 

These lines are fairly self-explanatory, except perhaps the last.  This is to transfer these data from the 
GenStat server into a new spreadsheet.  It is the command equivalent of Spread ⇒ New ⇒ Data in 
GenStat. For more information on any of the other lines, you could either go straight to the Help 
system, for example just type the command and press F1, or look for the equivalent dialogue. 

Before that we had the 2 lines: 
 

CALC success=(rainsum3>20).and.(DayfromSept>30) 
RESTRICT Date, YearfromSept, rainsum3; success 
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The first is a ‘logical’ calculation, which returns the value 1, for true, or 0 for false.  Then we used the 
command equivalent of the Spread ⇒ Restrict/Filter dialogue to look at just the days when planting 
was possible.  

So where is the pain? Well what is the point of the group command in the following two lines? 
      CALC YearfromSept=year(Date)+(Month(Date)>8) 

GROUP [redefine=yes] YearfromSept  

and what on earth does the second line do in the following part of the code? 
      TABULATE [class=YearfromSept] Date; min=start 
      VTABLE start; startdate;!p(yr) 

In particular what does !p(yr) mean in that line? 

The first two lines can give a clue to the problem.  Having calculated the column called 
YearfromSept, we need to change it into a factor column, so we can use it later to get the summary 
for each year.  This is easy in the spreadsheet, just right-click and change to a factor.  The GROUP 
command is a way of doing the same thing.   

More generally GenStat recognizes different “data types” including variates, factors, matrices, tables 
and pointers.  They are all described in Chapter 2 of the syntax and data management guide, see 
Help ⇒ GenStat Guides.  Understanding the role of these structures is needed to be able to write 
most programs.  So you will need to check in that chapter, and hopefully have explanations from 
some more simple examples22.   

16.5.3 Repeating sets of commands 

We now start the real payoff from using commands.  It is easy to repeat sets of 
commands, possibly for different stations or different criteria.  This is much simpler than 
having to go through the menus repeatedly.  One way is to change the program given in 
Fig. 16.5a.  Here we show how we can repeat sets of commands within a single run of 
the program. 

In this section we generalize the program to look at four different earliest dates that the season could 
start.  We have set them at 30, 40, 50 and 60 days after the initial date of 1st September, but the user 
could change these. The new file containing the commands is called start2.gen and is shown in Fig. 
16.5g. When this file is run, the spreadsheet, shown in Fig 16.5f, is created.  The first column gives 
summary statistics when the earliest possible starting date was 1st October.  Then for example Q1, 
the first quartile, shows that planting was possible in 25% of the years by day 50.  September 1st was 
taken as day 1, so this is 19th October. 

Fig. 16.5f Summary statistics for starting dates 

 

                                                 
22 You need to know a little about tables and pointers to follow the two lines of code, starting tabulate 
and vtable.  In the tabulate command the days of the start are automatically stored in a table 
structure. This is useful, because the table automatically stores the year numbers as well as the 
starting dates.  Then the vtable line is used to change this table into columns, and we chose the 
names Startdate for the dates, and yr, for the corresponding year number. 
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Fig. 16.5g Adding a loop to the commands 

 
 

In the command file, shown in Fig.16.5g, the key lines are those with FOR and then ENDFOR.  
These are described in Chapter 5.2.1 in the GenStat Syntax and data Management guide, which is 
accessed through the help system.  Other controls described in that chapter are 
IF…ELSIF…ELSE…ENDIF and CASE…OR…ELSE…ENDCASE. 

For example in the program in Fig. 16.5g we might want to analyse the data only if there are more 
than 5 years of data or if there are not too many missing values.  To do this we could add lines such 
as 
CALC check=nobs(Rain)/366 
IF check > 5  
 “Do all the commands” 
ELSE 
 PRINT ‘At least 5 years of data are needed for this analysis’ 
ENDIF 

This example indicates that it is quite easy to generalize a simple program, such as the one we 
started with in Chapter 16.5.1 

16.5.4 Making a program into a procedure 

We have emphasized that part of the value of writing commands is that the user can easily make 
changes to tailor the analysis to their requirements.  For example in Fig. 16.5a the name of the station 
could be changed from zimdata.gsh and the earliest date could be changed from 1st October, by 
changing the value of 30 in the code. 

One problem with the programming in Fig. 16.5a is that it forces the user to dig into the code to make 
these changes.  It is not good programming practice to “hardwire” the station name, or 1st October in 
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the code.  This is not a serious problem with such short programs, but can be awkward in general as 
this can lead to mistakes. 

A simple improvement is to put all the components that the user might change at the start of the 
program.  So we could have:  
TEXT [n=1]StationName; value = ‘zimdata.gsh’ 
SCALAR Earliestdate; value=30 

Then we would use these names in the code, for example 

IMPORT StationName  instead of  IMPORT ‘zimdata.gsh’ 
Even better would be to take anything like this out of the code altogether.  This is the process of 
writing a procedure, as described in Chapter 5.3 and 5.4 of the GenStat Syntax and Data 
Management guide. 

Many procedures have been written for GenStat.  To see the code you can use Help ⇒ Procedure 
Source, and then select a procedure.  Local or special interest groups can also add their own 
libraries of procedures, using Tools ⇒ Procedure Libraries ⇒ Attach.  The help associated with 
attaching these libraries is shown in Fig. 16.5h.  This opens the possibility of adding a library to 
include further facilities for the analysis of climatic data. 
 

Fig. 16.5h Attaching a procedure library 

 
 

We sometimes find that staff who are comfortable at computing, though not programmers, assume 
that it will be impossible for them to write procedures.  This is not the case. 

We therefore give two small challenges.  They demonstrate that you can start with procedures as you 
might start writing commands, namely by changing one that exists, rather than writing your own.  The 
first task is as follows.  If you were to run the commands that we showed in Fig. 16.5g, you would see 
that the results are not quite as we show in Fig. 16.5f. The results are given in a different order, and 
we changed the order in the spreadsheet to display the summaries in a more logical order.  They are 
given by the DESCRIBE procedure, which is also what is run automatically when you use the Stats 
⇒ Summary Statistics ⇒ Summarise Contents of Variates menu. Could you change the code in 
the DESCRIBE procedure, so the results are given in the same order as shown in Fig. 16.5f?   

Use Help ⇒ Procedure Source to get the exiting code for DESCRIBE and you may be surprised 
how easy it is to make the change.  So much so, that we suggest a second task.  Suppose you were 
also asked to get the 10% and 90% points of the starting dates, as well as the quartiles.  Currently the 
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procedure permits any of 22 summary statistics, but not those.  Could you make the 22 into 24, by 
adding the option to give these percentiles? 

Understanding how easy it is to write procedures is important, even if you have little intention of 
becoming a programmer.  Perhaps you will suggest some tasks for others, or commission a 
programmer.  Then knowing just a little about writing procedures will greatly help you to define exactly 
what would be useful for you, or for your organization.  

16.5.5 Making procedures visual 

Apart from this chapter you have been using GenStat mainly through menus and dialogues.  In this 
section we have now seen that it is possible to add your own procedures to those that are currently 
available in GenStat.  In this final section we look at how we can give these additions their own 
menus and dialogues. 

Although it is possible to create menus and dialogues for existing procedures, we provide two 
examples of a user procedure and then demonstrate how to create a custom dialogue for each one. 
This is because we wish to emphasise the fact that the ability to create custom procedures and 
dialogues enhances the value of GenStat’s link to R and WinBugs. A user can now write a procedure 
to access the facilities in R, for example, and then create a dialogue in order to make the process 
user friendly. For more information on the link to R, see “An Evaluation of GenStat’s Link to R using 
Extreme Value Analysis”, which is the SSC’s guide for those who wish to evaluate the potential of the 
link. 
 

Example 1: Comparing nested GLMs using the Deviance Statistic  
The first user procedure, shown in Fig 16.5i, calculates a deviance statistic and the associated p-
value, given the residual deviance of two nested generalized linear models (GLMs). The procedure 
assumes that the scale parameter is known.  
 

Fig. 16.5i Code for the user procedure DEVSTAT 
PROCEDURE [WORDLENGTH=short] 'DEVSTAT' 
OPTION  'PHI';  " I: scale parameter "\ 
  MODE=p;  DEFAULT=1; DECLARED=yes; TYPE='scalar'; PRESENT=yes; LIST=no 
PARAMETER NAME=\ 
  'D1',  " I: residual deviance under model M1"\ 
  'D0',  " I: residual deviance under model M0, where M0 is nested in M1 "\ 
  'K';   " I: number of extra parameters in M1 "\   
  MODE=p; SET=yes; DECLARED=yes; TYPE='scalar'; PRESENT=yes  
 
CALC DevianceStat = (D0-D1)/PHI 
CALC p = CUCHISQUARE(DevianceStat;K) 
PRINT DevianceStat, p 
 
ENDPROCEDURE 

The commands can be entered in a new Input Window and then saved as a procedure input file, 
using the extension gpi. The code shown in Fig 16.5i can be found in the file DEVSTAT.gpi. It must 
be saved in the GenStat add-ins folder, which is called AddIns and can be found in the GenStat 
version 11 program file folder (Gen11ed), for example C:\Program Files\Gen11ed\AddIns. 

Run the code using Run ⇒ Submit Window. Now open the Build Procedure Library using Tools ⇒ 
Procedure Libraries ⇒ Build. 

Any procedures submitted during the current session will be stored in the folder User, under 
Available procedures. Expand the folder and move DEVSTAT to the box under Procedures in 
library. Ensure that the Create new library radio button is selected. Enter a name for your new 
library in the box labeled File. Here, we have used MyLibrary. Finally, click on Browse to find the 
GenStat add-ins folder and then click on Build Library. The completed dialogue is shown in Fig. 
15.5j. 
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Fig. 15.5j completed Build Procedure Library dialogue 

 
 
 

The DEVSTAT procedure can now be used, as normal, by running it from an Input Window. For 
example, try 
 
DEVSTAT [PHI = 1] D1=54; D0=60; K=2 
 
which gives the following output: 
 
    DevianceStat                     p 
 6.000  0.04979 
 
Here, we are comparing the residual deviance of model M0 with that of model M1, where M0 is 
nested in M1. The residual deviance of model M1 is labeled D1 and is equal to 54. The residual 
deviance of model M0 is labeled D0 and is equal to 60. M1 has K=2 extra parameters. The results 
show that the reduction in residual deviance corresponding to the two extra parameters is 6. 
Comparing this with the chi-squared distribution on 2 degrees of freedom, this reduction is significant 
at the 5% level. 
 
Custom Dialogues 
The layout and contents of custom dialogues can be created using the ‘GenStat resource language’. 
The basic structure of the language is as follows: 
 
DIALOG id, width, height 
CAPTION text 
PROCEDURE text 
BEGIN 
... 
... Dialogue Controls (layout and contents instructions) ... 
... 
END 
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DIALOG statement 

The DIALOG statement defines the id of the dialogue and its size. The statement requires two or 
three parameters depending on how the size of the dialogue is specified.  

Parameter 1:            id - a unique id for the dialog.  
 

Parameter 2:           size - the size of the dialog (SMALL, MEDIUM or LARGE). 
or 
Parameters 2 & 3:    width - the width of the dialog.  
                height - the height of the dialog.  
 

CAPTION statement 

This has one parameter that specifies the title that will appear on the dialogue title. The text should be 
in double quotes, e.g. "My Dialog Title". 

 

PROCEDURE statement 

This has one parameter that specifies the name of the procedure that will be called when the dialogue 
is run. The name of the procedure should be supplied in double quotes. The procedure name can be 
up to 32 characters where the first character must be a letter and the second to the 32nd can be 
either letters or digits.  

 

BEGIN and END statement 

These statements have no parameters and are used to indicate the start and end of the controls that 
are to be added to the dialog. 
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Dialog Controls 

The dialogue controls are the objects that the user interacts with. They make the link between the 
dialogue and the procedure. The following controls are available: 

 
Statement  Dialog 

Control 
Description Example 

PUSHBUTTON  Push button 

Creates a button that tells 
GenStat to carry out an 
action, such as Run to submit 
the dialogue, Cancel to close 
the dialogue, or Help to open 
a help file. 

 

IMAGEBUTTO
N  Image button 

Creates buttons that allow the 
dialogue to remain open when 
activated, a clear button to 
reset the dialogue and/or a 
help button. 

 

CHECKBOX  Check box 

A box that can be clicked on 
and off or used to represent a 
set of options that returns a 
list of strings. 

 

TOGGLEBOX  Check box 
A box that can be clicked on 
and off or used to return a 
string for a true or false result. 

 

RADIOBUTTON  Radio Button 

Creates a radio button control. 
Should be displayed in groups 
where only one button can be 
selected at a time.  

LTEXT  Static text Allows you to place read-only 
text into the dialog.  

GROUPBOX  Group box 

Draws a rectangle around a 
group of controls and inserts a 
user specified title in the top 
border.  

EDITTEXT  Edit control 

Creates an input box which 
can be typed into or can 
accept data from an available 
data list. 

 

COMBOBOX  Combination 
box 

Creates a drop-down box 
containing a list of options. 

LISTBOX  List box 
Creates a box containing a list 
from which the user can select 
one or more items.  

  

Further information on the dialogue controls can be found in Help under GenStat resource 
language. It explains the options available and how to write the code. 

Fig. 16.5l shows an example of the resource language that creates a dialogue for the DEVSTAT 
procedure. The dialogue produced by this example is shown in Fig. 16.5k. 

 

 



16 – Moving from menus to commands Analysing climatic data using GenStat for Windows 

192 

Fig 16.5k The custom Deviance Statistic dialogue 

 
 
 

Fig. 16.5l Code to create the custom dialogue for the DEVSTAT user procedure 
DIALOG dialog1, 160, 128 
CAPTION "Deviance Statistic" 
PROCEDURE "DEVSTAT" 
BEGIN 
  PUSHBUTTON "Run", IDRUN, 24, 110, 54, 14, BS_RUN 
  PUSHBUTTON "Cancel", IDCANCEL, 84, 110, 54, 14, BS_CANCEL 
  GROUPBOX "Residual Deviance", IDSTATIC, 4, 21, 135, 30 
  LTEXT "(model M0 nested in model M1)", IDSETUP, 4, 5, 105, 9 
  LTEXT "M0:", IDMO, 8, 35, 15, 9 
  EDITTEXT D0, 25, 33, 40, 14, GW_PARAM | EC_SET 
  LTEXT "M1:", IDMI, 75, 35, 15, 9 
  EDITTEXT D1, 92, 33, 40, 14, GW_PARAM | EC_SET 
  LTEXT "Number of extra parameters in M1:", IDK, 4, 65, 110, 9 
  EDITTEXT K, 117, 63, 35, 14, GW_PARAM | EC_SET 
  LTEXT "Scale Parameter:", IDPHI, 4, 85, 60, 9 
  EDITTEXT "1", PHI, 67, 83, 20, 14, GW_OPT | EC_SET 
END 

 
Explanations of the code 

DIALOG: 

The dialogue ID is dialog1 and it has a width of 160 and a height of 128 units. 

CAPTION: 

The title of the dialogue is Deviance Statistic. 

PROCEDURE: 

The DEVSTAT procedure will be activated using the inputs entered by the user. 
 

Dialogue Controls 

PUSHBUTTON: 

The text on the first pushbutton is Run. The GenStat name (user defined id) for this button is IDRUN. 
The top left hand corner of the button is positioned at co-ordinates (24,110). The width of the button is 
54 and height is 14. BS_RUN creates a Run button that activates the attached procedure and closes 
the dialogue. 
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The text on the second pushbutton is Cancel. The id for this button is IDCANCEL. The top left hand 
corner of the button is positioned at co-ordinates (84,110). The width of the button is 54 and height is 
14. BS_CANCEL creates a cancel button that closes the dialogue without saving any changes. 

GROUPBOX: 

Wraps around and provides the title Residual Deviance for the model deviance input boxes. The id 
for the group box is IDSTATIC. The top left hand corner of the box is positioned at co-ordinates 
(4,21). The box has a width of 135 and a height of 30.  

LTEXT: 

The first line of text informs the user that the calculation assumes that model M0 is nested in model 
M1.  

The text M0: informs the user that the residual deviance for model M0 must be entered in the 
adjacent box.  

EDITTEXT: 

Creates an input box for the DEVSTAT procedure parameter D0. The id D0 informs GenStat that the 
value entered in this box is the corresponding DEVSTAT procedure parameter D0. The id must be the 
same name as the procedure parameter (or option) that the input is for. The top left hand corner of 
the input box is positioned at co-ordinates (25,33). GW_PARAM specifies that the input box is for a 
parameter in the attached procedure. EC_SET checks that text has been entered into the input box 
when the attached procedure is run. If no text has been entered an error prompt appears. 

The last EDITTEXT control creates an input box for the DEVSTAT procedure option PHI. The "1" 
creates a default entry of 1 that is displayed in the input box when the dialogue is opened. This entry 
can be changed by the user. 
 
The code must be entered into an Input Window and then saved with the extension .grc, for example 
devstat.grc. Save the file in the GenStat add-ins folder, which is called AddIns and can be found in 
the GenStat version 11 program file folder (Gen11ed), for example C:\Program 
Files\Gen11ed\AddIns. Note that you must type the ‘.grc’ extension rather than by selecting it from a 
drop-down menu. 

To attach the custom dialogue menu to GenStat, an add-in file must be created. The layout of the file 
is as follows: 

[AddInX]  
Type = DIALOG 
ProgID = my dialogue id 
MenuTitle = name in menu 
ResourceFile = dialogue code.grc 
 

• The text in bold is fixed (it must appear in the file) and the underlined text in italics is user     
    dependent. For [AddInX], X  must be a number i.e. AddIn1, AddIn2 etc.  

• For ProgID, my dialogue id must be the same name that was assigned to the dialogue id  
    under DIALOG. Here, we used dialog1. 

• For MenuTitle, name in menu is the name that you wish to see in the menu. In our   
    example, we will use the title Deviance Statistic. All custom dialogues appear under the   
    User menu, which means that our dialogue can be accessed through User ⇒ Deviance   
    Statistic, as below. 

 
 

• For ResourceFile, dialogue code.grc must be the name of the file containing the code to  
    create the custom dialogue, which  is devstat.grc in our example. 

 
The code for the add-in file for our example is shown in Fig 16.5m. 
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Fig. 16.5m Code to create the add-in file for the custom dialogue 

[AddIn1] 
Type=DIALOG 
ProgID=dialog1 
MenuTitle=Deviance Statistic 
ResourceFile=devstat.grc 
 
This file must also be saved in the GenStat add-ins folder. It is a GenStat add-in file (GAD file), which 
means that it should be saved using the file extension .gad, for example, devstat.gad. The next time 
you start GenStat, the custom dialogue should attach automatically and the dialogue can be opened 
using User ⇒ Deviance Statistic, as shown above. 

Now we can generate the same answer as we did when we used the DEVSTAT command 
DEVSTAT [PHI = 1] D1=54; D0=60; K=2 

by filling in the dialogue as shown in Fig. 16.5n. 

 
Fig. 16.5n Deviance Statistic dialogue 

 
 
Click on Run to generate the following output: 
 
   2  DEVSTAT [PHI=1] D0=60; D1=54; K=2 
  
 DevianceStat  p 
 6.000    0.04979 
 
 
 
Example 2: Transformations 
The second example uses an adapted version of a user procedure called TRNSFRM, which is 
introduced in GenStat Help under Custom menus example – transformations. Both procedures 
perform a simple transformation on a variate, allowing the results to be saved and displayed in a 
spreadsheet. Our version of the procedure, (TRNSFORM) has, in addition, the option to square or 
square root the variate and to request the mean of the transformed variate. The code can be found in 
the datasets folder in the file TRNSFORM.gpi, and is shown in Fig. 16.5o. The dialogue produced by 
this example is shown in Fig. 16.5p. 
 
 
 
 
 
 
 
 



Analysing climatic data using GenStat for Windows 16 – Moving from menus to commands 

 195 

 
Fig. 16.5o Code for the user procedure TRNSFORM 

DELETE [REDEFINE=yes; PROCEDURE=yes] TRNSFORM 
PROCEDURE [WORDLENGTH=long] 'TRNSFORM' 
OPTION 'PRINT','TRANSFORM','SPREADSHEET'; \ 
  MODE=t; LIST=y,n,n;\ 
  VALUES=!T(max,min,mean,none),\ 
         !T(ln,log10,exp,pwr10,sqrt,square,logit),\ 
         !T(yes,no);\ 
  DEFAULT= !T(none),!T(ln),!T(no) 
PARAMETER 'X','NEWX';\ 
  TYPE='variate';\ 
  SET=yes,no;\ 
  DECLARED=yes,no;\ 
  PRESENT=yes,no 
 
ASSIGN [METHOD=preserve] lnx; NEWX 
IF TRANSFORM.eqs.'ln' 
    CALC NEWX = LOG(X) 
ELSIF TRANSFORM.eqs.'log10' 
    CALC NEWX = LOG10(X) 
ELSIF TRANSFORM.eqs.'exp'   
    CALC NEWX = EXP(X) 
ELSIF TRANSFORM.eqs.'pwr10' 
    CALC NEWX = 10**X 
ELSIF TRANSFORM.eqs.'sqrt' 
    CALC NEWX = SQRT(X) 
ELSIF TRANSFORM.eqs.'square' 
    CALC NEWX = X*X 
ELSE  
    CALC NEWX = LOGIT(X) 
ENDIF 
 
CALC minx = MIN(NEWX) 
CALC maxx = MAX(NEWX) 
CALC meanx = MEAN(NEWX) 
 
IF 'max'.IN.PRINT 
  PRINT [IPRINT=*] 'Maximum of transformed data is',maxx 
ENDIF 
IF 'min'.IN.PRINT 
  PRINT [IPRINT=*] 'Minimum of transformed data is',minx 
ENDIF 
IF 'mean'.IN.PRINT 
  PRINT [IPRINT=*] 'Mean of transformed data is',meanx 
ENDIF 
 
IF 'yes'.EQS.SPREADSHEET 
  FSPREADSHEET [SHEET=0] NEWX;  
ENDIF 
ENDPROCEDURE 
 

 
 
 
 
 
 
 
 
 
 
 



16 – Moving from menus to commands Analysing climatic data using GenStat for Windows 

196 

 
Fig. 16.5p Custom Transformation dialogue 

 
 

Follow the steps below to add the custom procedure and dialogue to GenStat: 
 

1. Open the file TRNSFORM.gpi and submit the code using Run ⇒ Submit Window 

2. Save the file in the GenStat AddIns folder 

3. Open the Build Procedure Library using Tools ⇒ Procedure Libraries ⇒ Build 

4. Click on the Modify existing library radio button and move TRNSFORM to the      
Procedures in library box, as shown in Fig. 16.5q. Click on Build Library. 
 

Fig 16.5q Build Procedure Library dialogue 
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5. Write the code to create a dialogue for the TRNSFORM procedure. This can be found in 
the file transform.grc and is shown in Fig. 16.5r. Save the file in the GenStat add-ins 
folder. 

Fig 16.5r Code to create the custom dialogue for the TRNSFORM user procedure 
DIALOG dialog2, 210, 195 
CAPTION "Transformation" 
PROCEDURE "TRNSFORM" 
BEGIN 
  PUSHBUTTON "Run", IDRUN, 20, 175, 54, 14, BS_RUN 
  PUSHBUTTON "Cancel", IDCANCEL, 78, 175, 54, 14, BS_CANCEL 
  PUSHBUTTON "Help", IDHELP, 136, 175, 54, 14, BS_HELP, "Transform.html" 
  LTEXT "Available Data:", ITEXT, 2, 2, 52, 9 
  LISTBOX IDLIST, 2, 12, 90, 120, GW_AVAILABLE 
  LTEXT "Data:", ISTATIC, 100, 2, 46, 9 
  EDITTEXT X, 100, 12, 100, 14, GW_AVAILABLE | DT_TYPVAR | GW_PARAM | EC_SET 
  LTEXT "Save in:",ISTATIC, 100, 32, 46, 9 
  EDITTEXT NEWX, 100, 42, 100, 14, GW_AVAILABLE | DT_TYPVAR | GW_PARAM | EC_SET 
  LTEXT "Transformation:", ISTATIC, 100, 64, 70, 9 
  COMBOBOX TRANSFORM, 100, 74, 90, 64, CB_DROPLIST | GW_OPT 
  SLIST TRANSFORM, "Log (base e)", "Log (base 10)", "Exponentiate", "Power of 10",    
  "Square Root", "Square", "Logit" 
  RLIST TRANSFORM, "ln", "log10", "exp", "10pwr", "sqrt", "square", "logit" 
  GROUPBOX "Display", IDSTATIC, 100, 94, 100, 52 
  CHECKBOX "Minimum", PRINT, 104, 106, 70, 14, GW_OPT | GW_SEL, "min" 
  CHECKBOX "Maximum", PRINT, 104, 118, 70, 14, GW_OPT | GW_SEL, "max" 
  CHECKBOX "Mean", PRINT, 104, 130, 70, 14, GW_OPT | GW_SEL, "mean" 
  TOGGLEBOX "Display data in spreadsheet", SPREADSHEET, 100, 154, 130, 14,GW_OPT,  
  "yes", "no" 

END 
 

Explanations of new code 
 

PUSHBUTTON  

“Help” creates a link to the help file Tansform.html. The help file must be saved in the add-ins folder. 
BS_HELP creates a Help button and “Tranform.html” is the name of the Help file, which is saved in 
the add-ins folder. 

LISTBOX 

Creates a list of variables from which the user can select one.  GW_AVAILABLE specifies that the list 
box is a list of available data. This allows the data to be double clicked into a text box or droplist 
combo box. 

EDITTEXT 

The first EDITTEXT command creates a text box to receive the variable selected from the list box. X 
(the id) and GW_PARAM (a flag) indicate that the selected variable name is to be returned to the 
TRNSFORM procedure as the parameter X. Note that we must use X here because the id must have 
the same name as the procedure’s parameter (or option) that the result is for. GW_AVAILABLE 
enables the data in an available data list box on the dialog to be double clicked into the text box. 
DT_TYPVAR restricts the data displayed in the available data list box to variates when clicking into 
this text box. EC_SET checks that text has been entered into the text box when the attached 
procedure is run. If not text has been entered an error prompt appears. 

COMBOBOX 

Creates a drop down box containing a list of available transformations. CB_DROPLIST indicates that 
the options cannot be edited by the user i.e. the choices are fixed. GW_OPT specifies that the combo 
box is for an OPTION in the attached procedure and the id TRANSFORM specifies the OPTION that 
the selection is destined for. 

SLIST 

Must be used with COMBOBOX in order to specify the list of available transformations. The id, which 
is TRANSFORM, must be the same as the id specified for the combo box. 
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RLIST must be used with COMBOBOX and SLIST in order to link the names of the available 
transformations specified under SLIST with the associated TRNSFORM OPTION. For example, if the 
user selects Square Root the procedure is supplied with TRANSFORM=sqrt. 

6. Create an add-in file (.GAD) to attach the dialogue to GenStat. This can be found in the file 
transform.gad and is shown in Fig. 16.5s. Save the file in the GenStat add-ins folder. 

Fig. 16.5s Transform add-in (GAD) file 
[AddIn2] 
Type=DIALOG 
ProgID=dialog2 
MenuTitle=Transform Data 
ResourceFile=transform.grc 

 

7. Save the help file Transform.html in the AddIns folder. 

8. Restart GenStat. 

9. Open a new spreadsheet and create a new variate called Time by entering the values 1 to 
10 in a column, as shown in Fig. 16.5t. 

Fig. 16.5t New spreadsheet containing the variate Time 

 

10. Access the custom dialogue using User ⇒ Transform Data and complete the dialogue as 
shown in Fig. 16.5u 

Fig. 16.5u Testing the Transformation dialogue. 
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11. Click on Run to generate the new column LogTime, as shown in Fig 16.5v. 

Fig 16.5v Spreadsheet with the transformed column LogTime 
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17. Challenge 5 – Changing a GenStat procedure 
In Chapter 16.1 we ran a procedure called DAYLENGTH.  In the help on this procedure it states: 
“The formula by which the daylengths is calculated is given in Sellers (1965)”. 

The first task is to find the formula.  One way is to find the article, but the second is to look at the 
contents of the procedure using Help ⇒ Procedure Source.  Alternatively you can use the 
command LIBSOURCE followed by the procedure name, for example:  

LIBSOURCE 'DAYLENGTH'  

This is possible for any procedure and the contents of the procedure DAYLENGTH are shown in 
Fig.17.1a. 

 Fig. 17.1a  Contents of the DAYLENGTH procedure 

 
 

Note that to write your own procedures, you start by giving a PROCEDURE statement. 

Find the procedure called DAYLENGTH and copy it in an input window, so it can be modified.   
⇒ Give the procedure a new name, for example the name of the place where you work.   
⇒ Change the default latitude from 52.205 to the latitude that you want.   
⇒ Try running your own version of the procedure. 

The procedure currently does not print anything.  Change it by adding the lines 
IF Nvalues < 40 
      PRINT DAYNUMBER, DAYLENGTH; dec = 0,2 
ELSE 
      PRINT ‘The results are saved in the variable called‘, !p(DAYLENGTH) 
ENDIF 

This should be inserted just before the ENDPROCEDURE line 

Now run it again. 
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18. Developing a strategy 

18.1 Introduction 
In this last chapter we look more generally at three aspects concerned with a strategy for processing 
climatic data.  They are on data, software and staff.  In Chapter 18.2 we consider aspects concerned 
with data entry and checking.  We look at the access to data from databases using ODBC (Open 
Database Connectivity) in Chapter 18.3.   

In Chapter 18.4 we examine software issues.  We consider where GenStat might fit into your software 
strategy:  What are some other alternatives and what other software might you use together with 
GenStat?   

Finally, in Chapter 18.5, we look at people, and include issues of training. 

We try to be as general as possible, so we hope the issues will be applicable whether you work in a 
Met Service, a University, or elsewhere. We also believe the issues are essentially the same 
whatever country you are in. 

18.2 Data 
A few people collect climatic data, but most users access the data from others, perhaps from a Met 
Service.  As well as the actual data you will usually have some further details; perhaps the location of 
the stations and details of the instruments used to take the measurements.  This is called meta-data.  
The information is often not usable without some meta-data. 

Met Services are sometimes protective about their data, but we see no reason why they should 
restrict access to the meta-data.  This information is very useful to help anyone specify what data they 
need.  In many developing countries a database system called CLICOM has been used to store the 
climatic data and meta-data.  The original CLICOM is now old fashioned, but the term CLICOM is 
sometimes used in a more generic way as countries adopt more modern versions of software for 
managing their climatic records.  One such system, called CLIMSOFT, is being developed largely by 
the Zimbabwe Met Service. Another, called CLIDATA (www.clidata.cz) has been developed by the 
Czech Met Service. 

Climatic data are also stored by many other organizations, including groups concerned with food 
security early-warning systems, universities, and so on.  We do not wish to enter here into the 
quagmire of data access from Met Services, though we would like to encourage them to have a well-
defined policy for data access.  And if this policy makes their data expensive, then they must not be 
surprised if users ignore their services, and look elsewhere for the data23.  

Even when the data are secondary, i.e. you did not collect them, we strongly encourage users to be 
critical about the data quality.  We illustrate by considering three topics.  The first is when you have 
the same data from two different sources and need to check whether they are really the same.   

We illustrate with the Zimbabwe data, though we had only the single copy.  GenStat can help in the 
following way.  Enter one copy of the data into a GenStat spreadsheet.  We used the data in the file 
called zimdata.gsh and made 2 changes, to “introduce” errors. We changed 23.7 to 24.7 in the first 
row of the data in Fig. 18.2a and deleted the 4th row of data.  Then use Spread ⇒ Sheet ⇒ 
Compare to give the dialogue shown in Fig. 18.2b.  

 

 

                                                 
23 Many organisations that try to charge for data, are themselves quite adept at “borrowing”, rather 
than paying for software.  They should assess whether their potential clients will be willing to pay for 
data, or will avoid the supplier.  This can marginalize the Met service, often the opposite of what 
should be encouraged. 
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         Fig. 18.2a Sheet with 2 faults     Fig. 18.2b The Spread ⇒ Sheet ⇒ Compare dialogue 

 

When we make the comparison the result is not very clear.  GenStat reports that the number of rows 
is not equal.  But then it starts by checking the year column, and so reports a mismatch on the column 
in line 184, when the data in memory gives 1952, while there is still one more row of 1951 in the file 
on the disc. 

In comparisons such as this, it is useful if there is a unique identifier for each row, and here this is a 
column called Date.  So we return to the menu in Fig. 18.2b and tick to match rows using the Date as 
the ID column.  The results are as follows and correctly identify the discrepancies: 
  "Comparing Spreadsheets: zimdata.gsh and zimdata.gsh 
     Unequal number of rows: 18197 vs 18198 
     Mismatch on Maxtemp at row 1: 24.7 <> 23.7 
     Row 4 in zimdata.gsh not matched. 
   Spreadsheets are different. " 
A different problem is when the data are on file, but you also have access to a paper copy.  In this 
case GenStat has an option for you to verify whether the two are the same.  Use Spread ⇒ Sheet ⇒ 
Verify to give the dialogue shown in Fig. 18.2c. We chose to check just the column with maximum 
temperatures.  The original values are no longer visible, as shown in Fig. 18.2d. 

Fig. 18.2c Spread ⇒ Sheet ⇒ Verify dialogue Fig. 18.2d Data ready to verify one column 

 
We typed the correct value, from the file, and this generated the error, shown in Fig. 18.2e.  We now 
have the choice between keeping what we just typed, or what was there before, or of now realizing 
that we were wrong both times!  We can also add a note, and have chosen to do so, see Fig. 18.2e. 
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Fig. 18.2e The GenStat dialogue when there is inconsistency 

 
 

After entering 2 values the screen is as shown in Fig. 18.2f, with the coloured cell indicating that there 
is a bookmark present.  GenStat also prepares a new spreadsheet that keeps a record of all the 
changes we have made.  This is shown in Fig. 18.2g, and indicates that both the first two rows were 
inconsistent. 

Fig. 18.2f The spreadsheet after verifying two rows 

 
 

Fig. 18.2g A special GenStat sheet with a record of changes 

 
 

In presenting these facilities, we do not suggest that you therefore consider using GenStat for the 
data entry and checking phase.  But their existence can be useful in discussions with the suppliers of 
the data, on what checks were made, when they were entered. 

In Part 2 of this guide we described some of the steps that are often needed to get your data into 
shape for the analysis.  It is important to allow sufficient time for this initial data manipulation stage. If 
the data manipulation is to be done on a routine basis for many stations then it will sometimes be 
more efficient to use commands, as described in Chapter 16, rather than just the menus and 
dialogues. 

In Chapter 7 we also illustrated some exploratory graphs that can be used to check the data.  This is 
different from the data entry checks described above.  The data may be transcribed correctly, but still 
be an odd value.   
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Sometimes we find the large volume of the raw data overwhelms users.  So they summarise the data, 
or (worse) they only start with the summary data.  Checking for oddities should be done at every 
stage, so we are happy that summary values are sensible. But when they are not, we need to be able 
to return to the raw data to see where the problems have arisen. 

It is also useful to consider what can be checked on the raw data directly.  It is also important to 
consider checks in relation to the specific objectives of the analysis.  For example if the study includes 
looking at the occurrence of dry spells, their occurrence is particularly sensitive to the recording of 
small rainfall amounts.  Typically some observers are more conscientious than others in recording 
small rainfalls, say those that are less than 1mm.  If the analysis is sensitive to this aspect, then this 
aspect should be checked.   

We illustrate with the Zimbabwe data. As an example, the first step, with the active cell in the rainfall 
column, is to use Spread ⇒ Calculate ⇒ Code to Groups. This gives the dialogue in Fig. 18.2h.  
With the limits we have chosen there, we see there were 1503 days with 5mm rainfall or more, and so 
on.  

Fig. 18.2h Checking the data prior to a dry-spells analysis 

 
 

Now use the Stats ⇒ Summary Statistics ⇒ Frequency Tables dialogue, as shown in Fig. 18.2i.  
 

Fig. 18.2i Stats ⇒ Summary Statistics ⇒ Frequency Tables 
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This gives the percentages of values in each group for each year, as shown in Fig. 18.2j. The final 
column in this table gives the count in each year.  We see that there are 365 values, with 366 in leap 
years. That is comforting!  Overall the bottom line indicates that 82% of the 18198 days were dry, and 
4% had rain of less than 1mm.  Looking at the individual years does not give any cause for concern. 

Fig. 18.2j Percentages of days each year in different rain groups 

 
 

The next step would be to look in more detail, probably by omitting the dry days, and looking at the 
important months in the year.  Some of the results could be displayed in graphical form. 

These checks do not take long.  It takes longer to decide on the appropriate action when there are 
problems.  But this is nowhere near as long as the time that is wasted if the analysis is done first, and 
then some problems are found.   

As a second example we show a trellis plot of the maximum and minimum temperatures for the daily 
data from Bulawayo (Zimbabwe) in Fig. 18.2k. This is designed more for the screen than the printer. 
This can be done using Graphics ⇒ Trellis and completing the dialogue as shown in Fig. 18.2l. 
 

Fig 18.2l Graphics ⇒ Trellis 
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Fig. 18.2k Trellis plot of the daily maximum and minimum temperatures 

 

 

If there are particular years or days that need closer inspection, then you can zoom in on parts of the  

plot, using the slider:   which can be found in the top right corner of  

the Graphics Viewer. We have zoomed in on the plot for 1967, as shown in Fig. 18.2m. 
 

Fig. 18.2m One year from Fig. 18.2j in more detail 
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18.3 ODBC 
Climatic data, with the associated meta-data, such as the station name and location, are usually kept 
in a database. This is often for many stations and hence each analysis is usually on a subset of the 
data in the database. 

Most statistics packages, including GenStat, can connect to a database and extract the data that are 
needed using ODBC (Open Database Connectivity). 

We illustrate using data from an Excel file. The process is similar for data from a database. 

You can choose to load the data directly into the GenStat server, or into a GenStat spreadsheet. We 
choose a spreadsheet, and therefore started with Spread ⇒ New ⇒ ODBC Data Query, see Fig 
18.3a.  

Fig. 18.3a Starting an ODBC data query 

 
 

The menu is then as shown in Fig. 18.3b (Note: The actual list of data sources that appears depends 
on what has been set up or installed on your computer).  We ask for Machine Data Source and state 
that we will use an Excel file. We then click on OK. 

Fig. 18.3b Specifying our data are in an Excel file 

 
 

If you do not find Excel in the list (Fig. 18.3b) on your machine, select Machine Data Source click 
on New (Fig. 18.3b), rather than OK.  Select User Data Source and click Next, Fig. 18.3c. Now 
select Microsoft Excel Driver (*.xls).  Click Next, then Finish. Then continue with the importing. 

We now specify the file, Fig. 18.3c, and choose the monthly data we used in Chapter 7 



18 – Developing a strategy  Analysing climatic data using GenStat for Windows 

 

210 

Fig. 18.3c Choosing the file 

 
 

Fig 18.3d Specifying the variables to input 

 
 

It is at this point, Fig. 18.3d that we see the distinction between the importing from Excel that we have 
done earlier, and the use of the ODBC facility. We can now choose which of the columns we wish to 
import. In this case we choose all of them. 
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Fig. 18.3e A subset of the rows (or cases) can be chosen 

 
 

We are then asked which rows to include, Fig. 18.3e. As an example, we choose to import only those 
for years from 1960. Then we have the final query, on whether we wish to continue with the import, or 
save the code that we have generated through this query. 
 

Fig. 18.3f The final step 

 
 

In Fig. 18.3f we click on Finish and the data are imported. 

18.4 Software 
This guide is deliberately called “Analysing Climatic data” with “using GenStat for Windows” as the 
afterthought.  Our emphasis is on the analysis, rather than the particular software.  In this section we 
outline the decisions on software that individuals and organizations might make, when analysing climatic 
data as a part of their work.  We limit ourselves primarily to decisions concerning statistical software. 
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The authors of this guide have no commercial interest in GenStat.  Our centre uses many statistics 
packages.  We produce only one package ourselves, and that is called Instat+24. It is available free to 
all individuals.  It is currently the only general statistics package that includes a special menu and 
guide for the analysis of climatic data. 

We still think that many users will wish to continue with Instat+ for some of their statistical analyses of 
their climatic data.  However, Instat+ is intended as an introductory package, and some users will 
need statistical software that is more powerful, for some of their applications. 

Before statistics packages were in Windows, they were command driven.  So you had to learn the 
language to be able to use the software.  This was a considerable effort, and hence users often 
limited themselves to a single package.  The ease of use of modern statistics packages has changed 
all that.  Cost apart, you no longer need to use a single package, but can consider the best mix for 
your work. 

Some users are content with a spreadsheet for their statistical work.  For most applications, the 
analysis of climatic data benefits from the addition of a statistics package.  This does not mean that 
you have to stop using the spreadsheet.  You can add the statistics package to your spreadsheet use. 

Another recent development is the ease with which statistics packages read data in different formats, 
and also are able to transfer data between different packages.  We saw the use of ODBC in the last 
section, and all common statistics packages read data from Excel.  Most also write back to Excel, so 
you can return to a spreadsheet, perhaps to draw some presentation graphs. 

Having decided that climatic analyses could benefit from the accessibility of a powerful statistics 
package, we describe below the criteria that made us choose GenStat.  But there is healthy 
competition in the statistics package market.  We hope that some readers might disagree with our 
choice.  Then perhaps they will produce a guide for the analysis of climatic data using an alternative 
package.  This will help users, and also encourage the suppliers to keep improving their products. 

SAS, SPSS, Systat, S-PLUS, R and Stata, see Fig. 18.4a, are among the other statistics packages that 
you might consider.  For those who currently use a statistics package, the same argument applies as for 
Excel users.  This need not be a competition between packages.  If facilities in this guide would add to 
what you do currently, then you could add GenStat to your repertoire.  This does not mean that you need 
to drop your current package.  There are, of course, issues of cost and of support.  We comment briefly 
on cost below and discuss issues of support for the different packages in Chapter 18.5. 

Fig. 18.4a Information on some statistics packages 

Package Key features (all include comprehensive statistical methods) 
SAS 

www.sas.com 

Industry standard.  Comprehensive facilities for both data management and 
analysis.  Provided in modular form, so you need to decide which components 
you need.  Annual licence. 

SPSS 

www.spss.com  

The other giant among the statistics packages.  Simple to use.  Modular. 
Popular for processing survey data.  Annual licence.  

Stata 

www.stat.com  

New comprehensive graphics and also menus in Version 10. Comprehensive 
language. Many libraries of procedures. Purchased. 

Systat 

www.systat.com  

Excellent graphics.  Already currently used by many Met Services for statistics 
involved in seasonal forecasting. Purchased. 

S-Plus 

www.insightful.co
m  

Modern object-orientated language based on S. Popular development tool for 
modern statistical methods. Excellent graphics. Purchased. 

R 

www.r-project.org  

Modern language, based on S.  Popular development tool for modern methods.  
Commands only, but keep checking.  Open source software. 

                                                 
24 We also produce an Excel add-in called SSC-Stat, which adds to the statistical facilities and 
encourages good statistical practice when using Excel. 
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Faced with the packages listed in Fig, 18.4a, and others, what criteria did we use to suggest writing 
this guide for GenStat?  Some of the reasons below reflect our interests in having software that is 
available and sustainable in developing countries. 

Cost and sustainability. We wanted software that was modestly priced, and also that could be 
bought, rather than requiring an annual rental.  While the rental is sometimes useful in providing 
automatic support and upgrades, it also means that some countries find it hard to sustain using the 
software, if external support stops.  Some users maintain there are no funds for software.  We did not 
restrict ourselves to free software, because most users seem to find funds for conferences and 
training.  Some of the packages above, including GenStat, are no more than a typical air fare, so 
having software is more a question of priorities, than funds. 

Ease of use.  Most of our users are not statisticians, and would use the software only occasionally.  
So we felt that the package must include a comprehensive menu system. 

Inclusion of required facilities and/or responsive development team.  We did not find the 
facilities we needed in any of the packages.  For example few packages included the statistics of 
extremes, see Chapter 15.2 and 15.3, or facilities to process circular data, Chapter 15.4 and 15.5.  S-
Plus and R, would have been acceptable if we had not required menus.  We were grateful that the 
GenStat development team undertook to add the commands for both topics, and include them in the 
menu system.  When we began our investigation of GenStat we found the menus and graphics for the 
multivariate analysis, Chapter 14, left much to be desired.  Our first draft of Chapter 14 was sent to 
the development team with 17 suggested improvements.  Some were added in a previous version, 
and were incorporated in the revised chapter. 

Promotion of good statistical practice.  While no statistics package promotes bad statistical 
practice, some are more active than others in actively promoting good statistical practice.  For 
GenStat this is partly the sense of responsibility felt by the development team, in coming from the 
home of R. A. Fisher!  In this guide an example of the “good practice” is seen in Chapter 11 on 
regression and Chapter 13 on the generalized linear models.  One aspect is the consistent use of 
factor columns for including categorical data in general regression models.  For example we find that 
some statistical packages have many routines for stepwise regression models, but they are 
commonly misused partly because they only apply if the models do not include factors. 

Useful for related applications.  In agricultural research, GenStat is an obvious package for the 
analysis of experimental data.  We would like to encourage more integration between the agricultural 
and climatic communities, and using the same software seems a useful aspect.    

Powerful language capabilities.  It is important that users can add further capabilities to the 
statistical software, as described in Section 16.5.  We consider that the facility to write procedures 
that extend the GenStat language, see Section 16.5.4 is important.   

Links to other software. A recent addition to GenStat is the links to R and WinBUGS, as mentioned in 
Sections 15.3 and 16.5.5. This means that it is possible to use the facilities that are available in all three 
packages, which widens the scope of GenStat, significantly. The fact that it is compatible with other 
programs means that GenStat can be used to carry out more types of analyses than other packages.  

Custom menus and dialogues. Less experienced users struggle with commands. The facility to add 
custom menus and dialogues (see Section 16.5.5) makes custom procedures accessible and easier 
to use. In combination with the links to other software, it makes GenStat very flexible and allows the 
user to perform virtually any calculation or data analysis that is required. 

As mentioned earlier, if anyone feels there is a better package, then we invite them to produce an 
equivalent guide. Users will benefit. 

Some users have special packages for statistical applications, either in addition, or instead of the 
general statistics packages, such as GenStat.  For example database packages for storing 
hydrological data often include facilities for their subsequent analysis.   

Software is also often used for applications where the data could subsequently be processed using a 
statistical package.  Examples include water balance models, such as CropWat, 
(http://www.fao.org/nr/water/infores_databases_cropwat.html) or crop simulation models, like DSSAT 
(http://www.icasa.net/dssat/) or APSIM (http://www.apsim.info/apsim/default.asp). 
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There are also some specialized statistics packages.  For example for modeling extremes there is a 
package called Xtremes (http://www.xtremes.de/extremwertanalyse_eng.shtml). Alternatively, there is 
the R package extRemes, which was mentioned at the end of Section 15.3. 

The facilities for analysis in these packages compete for your time with the facilities offered by the 
general statistics packages.  Until recently part of the case for more specialized packages was a 
combination of the non-statistical facilities they offer, like crop modeling, plus the automatic 
calculation of results.  The first part will remain.  We anticipate that more users will start using these 
packages in conjunction with a general statistics package to process the output.  We will be interested 
to follow the situation with specialist software that competes directly with the general statistical 
packages.  Some will add attractively to the competition.  Others may find it hard to provide the 
upgrades, new facilities, and availability on new computers that users will demand. 

Users should be wary of software, even if free, if it has no upgrade path.  Some software that is free 
in direct cost may be expensive in demands on your time, perhaps on a training course, if the 
package does not add to your software strategy. 

18.5 Users 
Staff and organizations should have a strategy for statistical software and applications.  An example 
of a strategy for statistical software is given by the University of Nairobi, on 
(http://www.ssc.rdg.ac.uk/bucs/Software_Strategy_in_an_Agriculture_Faculty.pdf). Avoiding a 
strategy often results in time being wasted on pointless training, and on practicing applications that 
use inappropriate software.   

For climatic applications the strategy may be personal, or by an individual Met Service, or a University 
department, or by regional support centers.   

In suggesting a strategy we do not wish to stifle change: quite the opposite.  For example if you 
request training, or someone proposes training, linked to new software, then it will be useful to relate 
this development to your existing strategy.  Then, part of the case is an explanation of how the new 
software or skills will enhance the strategy. 

In the past there has been regular demand for training in statistics.  Sometimes courses that purport 
to train in statistics are diverted into teaching users how to master the statistical software.  We find 
that this phase is largely over.  This is because of the improved computing skills of users, combined 
with the ease of use of modern statistics packages.  Typically we find a course that uses GenStat 
requires only a single session to teach the use of the software, rather than the statistics.  Later 
sessions give more experience in the software, but the main emphasis can be on the statistical ideas.   

This development has permitted short in-service courses to be much more effective. 

However this ease of use is largely restricted to the use of the menus and dialogues in modern 
statistics packages.  More time is needed on the software if users are required to master some of the 
language.  We explained the value of knowing something of the commands in GenStat in Chapter 16.  
As part of their strategy, we encourage organizations and individuals to define how staff will acquire 
different levels of expertise.   

As an example we compare the typical use of database and spreadsheet software in an organization.  
Usually just a few people are required to master database software, so they can design the 
databases used by the organization.  The remaining staff may use these databases, but would not be 
expected to be part of the design phase. 

In contrast we often find organizations have no strategy in supporting staff in their use of 
spreadsheets.  They are so easy that their use is a “free-for-all”.  This often contributes to staff 
wasting time on ineffective use of the spreadsheet software, because there is no one to advise on 
efficient use.  It would often save time if a few users became “experts” in the use of a spreadsheet, 
and were then able to help others, where needed.  With Excel this might extend to one or two people 
learning some of the “command language”, called VBA, so they can tailor Excel’s capabilities to the 
precise needs of the organization.  This also applies to other commonly used software.  For example 
more use of styles, templates, outlines and even master documents, might support effective use of 
Microsoft Word and PowerPoint. 
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